---
id: "CVE-2026-61992"
kind: "vulnerability"
aliases: ["CVE-2026-61992"]
title: "GEO my WordPress plugin: unauthenticated PHP object injection through 4.5.5.3"
severity: "critical"
cvss: 9.8
epss: null
exploited: false
status: "open"
category: "package"
products: [{"name": "geo-my-wp", "fixed": ["4.5.5.4"], "affected": "<= 4.5.5.3", "ecosystem": "wordpress"}]
ecosystems: []
tags: ["geo-my-wordpress", "package", "php-object-injection", "self-hosted", "wordpress"]
not_affected_if: ["plugin-not-installed"]
published_at: "2026-10-29T16:18:11+00:00"
first_seen_at: "2026-10-29T16:25:59+00:00"
updated_at: "2026-10-29T16:31:38+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-61992", "first_seen_at": "2026-10-29T16:25:59+00:00"}, {"source": "analyst", "url": null, "first_seen_at": "2026-10-29T16:31:38+00:00"}]
---

# GEO my WordPress plugin: unauthenticated PHP object injection through 4.5.5.3

The GEO my WordPress plugin up to version 4.5.5.3 deserializes attacker-supplied PHP objects without authentication. An attacker who sends a crafted request may be able to run code or manipulate the site, with a CVSS score of 9.8.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- wordpress:geo-my-wp affected <= 4.5.5.3 fixed 4.5.5.4

## How to check

Run 'wp plugin get geo-my-wp --field=version' or look under Plugins in wp-admin. Versions 4.5.5.3 and lower are vulnerable.

## Fix

Update GEO my WP to 4.5.5.4 or later; 4.5.5.7 is the current release on wordpress.org and also covers later fixes.

## Timeline

- 2026-10-29T16:25:59+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-61992
- 2026-10-29T16:31:38+00:00 analyst — Patchstack (CNA) lists fixed in 4.5.5.4, reported 13 Sep, published 13 Oct 2026; wp.org shows latest 4.5.5.7 (a later Broken Access Control affects <=4.5.5.5, so go to latest). Endpoint/gadget chain not public; no PoC or exploitation found. Not verified: only Patchstack, not the maintainer's changelog entry for 4.5.5.4, was read.

## Documents

- [advisory] Patchstack: GEO my WordPress <= 4.5.5.3 PHP Object Injection (CVE-2026-61992) https://patchstack.com/database/wordpress/plugin/geo-my-wp/vulnerability/wordpress-geo-my-wordpress-plugin-4-5-5-4-php-object-injection-vulnerability
- [fix] GEO my WP on wordpress.org (changelog, latest 4.5.5.7) https://wordpress.org/plugins/geo-my-wp/

## From the sources

Unauthenticated PHP Object Injection in GEO my WordPress <= 4.5.5.3 versions.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
