---
id: "CVE-2026-61989"
kind: "vulnerability"
aliases: ["CVE-2026-61989"]
title: "Easy Property Listings WordPress plugin: unauthenticated XSS through versions 3.5.25"
severity: "high"
cvss: 7.1
epss: null
exploited: false
status: "open"
category: "package"
products: [{"name": "Easy Property Listings", "fixed": ["3.5.26"], "affected": "<= 3.5.25", "ecosystem": "wordpress"}]
ecosystems: []
tags: ["easy-property-listings", "package", "wordpress", "wordpress-plugin", "xss"]
not_affected_if: ["plugin-not-installed"]
published_at: "2026-10-29T16:18:11+00:00"
first_seen_at: "2026-10-29T16:25:59+00:00"
updated_at: "2026-10-29T16:36:57+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-61989", "first_seen_at": "2026-10-29T16:25:59+00:00"}, {"source": "analyst", "url": null, "first_seen_at": "2026-10-29T16:36:57+00:00"}]
---

# Easy Property Listings WordPress plugin: unauthenticated XSS through versions 3.5.25

The Easy Property Listings WordPress plugin, versions up to and including 3.5.25, has a cross-site scripting flaw that needs no login. An attacker can get script to run in a visitor's browser on a site running the plugin.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- wordpress:Easy Property Listings affected <= 3.5.25 fixed 3.5.26

## How to check

In WordPress admin > Plugins, check Easy Property Listings version; 3.5.25 or lower is vulnerable. Or run: wp plugin get easy-property-listings --field=version

## Fix

Update Easy Property Listings to 3.5.26 or later (3.5.28 is the latest listed by third parties).

## Timeline

- 2026-10-29T16:25:59+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-61989
- 2026-10-29T16:36:57+00:00 analyst — Vendor changelog confirms 3.5.26 (2026-10-12) fixes unauthenticated XSS via epl_action and search widget; WPScan/Patchstack agree on <=3.5.25 fixed 3.5.26. Vendor says reflected, WPScan says stored: discrepancy noted. No exploitation or PoC found; no X search done.

## Documents

- [advisory] WPScan: Easy Property Listings < 3.5.26 Unauthenticated Stored XSS https://wpscan.com/vulnerability/1366bfea-5321-43d9-b46d-b4b41a604dbc/
- [advisory] Patchstack: Easy Property Listings <= 3.5.25 XSS https://patchstack.com/database/wordpress/plugin/easy-property-listings/vulnerability/wordpress-easy-property-listings-plugin-3-5-25-cross-site-scripting-xss-vulnerability
- [fix] Easy Property Listings change log (3.5.26) https://easypropertylistings.com.au/change-log/

## From the sources

Unauthenticated Cross Site Scripting (XSS) in Easy Property Listings <= 3.5.25 versions.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
