---
id: "CVE-2026-57914"
kind: "vulnerability"
aliases: ["CVE-2026-57914", "GHSA-x6vc-x4v4-hjhr"]
title: "Apache Kerby vulnerable to denial of service"
severity: "medium"
cvss: 6.5
epss: 0.00436
exploited: false
status: "open"
category: "package"
products: [{"name": "org.apache.kerby:kerby-asn1", "fixed": ["2.1.2"], "affected": "< 2.1.2", "ecosystem": "maven"}]
ecosystems: ["maven"]
tags: ["cwe-400", "java", "kerberos", "kerby", "maven", "package"]
not_affected_if: ["kerby-asn1-not-used", "trusted-input-only"]
published_at: "2026-06-26T12:16:33+00:00"
first_seen_at: "2026-11-03T21:57:18+00:00"
updated_at: "2026-11-03T22:07:19+00:00"
sources: [{"source": "ghsa", "url": "https://github.com/advisories/GHSA-x6vc-x4v4-hjhr", "first_seen_at": "2026-11-03T21:57:18+00:00"}, {"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-57914", "first_seen_at": "2026-11-03T22:07:19+00:00"}]
---

# Apache Kerby vulnerable to denial of service

Apache Kerby's ASN.1 parser can be made to overflow the stack by a deeply nested ASN.1 structure sent to a Kerby client or service. The result is a crash, which means a denial of service.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- maven:org.apache.kerby:kerby-asn1 affected < 2.1.2 fixed 2.1.2

## How to check

- Check whether the project depends on `org.apache.kerby:kerby-asn1` below `2.1.2`, for example with `mvn dependency:tree`
- Look for `kerby-asn1` in the Maven lock or dependency report of each service that handles ASN.1 or Kerberos input

## Fix

- `org.apache.kerby:kerby-asn1` moves to `2.1.2`

## Timeline

- 2026-11-03T21:57:18+00:00 ghsa https://github.com/advisories/GHSA-x6vc-x4v4-hjhr
- 2026-11-03T22:07:19+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-57914

## Documents

- [fix] Patch: github.com https://github.com/apache/directory-kerby/commit/0bcd73eb9eb54622b84539b5fc23066057c6b5e8
- [fix] Release: github.com https://github.com/apache/directory-kerby/releases/tag/kerby-all-2.1.2

## From the sources

By sending a deeply nested ASN1 structure to a Apache Kerby client or service, it's possible to trigger a StackOverFlow Exception which can lead to denial of service issues. Users are recommended to upgrade to version 2.1.2, which fixes this issue.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
