---
id: "CVE-2026-56091"
kind: "vulnerability"
aliases: ["CVE-2026-56091", "GHSA-qj64-jj84-w38j"]
title: "Apache Shiro shiro-guice module vulnerable to authentication bypass"
severity: "high"
cvss: 8.2
epss: 0.00669
exploited: false
status: "open"
category: "package"
products: [{"name": "org.apache.shiro:shiro-guice", "fixed": ["3.0.0"], "affected": ">= 2.0.0, < 3.0.0", "ecosystem": "maven"}]
ecosystems: ["maven"]
tags: ["apache-shiro", "cwe-289", "java", "maven", "package", "servlet", "shiro-guice"]
not_affected_if: ["no-shiro-guice", "non-servlet-context"]
published_at: "2026-06-25T09:16:46+00:00"
first_seen_at: "2026-11-03T21:24:57+00:00"
updated_at: "2026-11-03T22:07:19+00:00"
sources: [{"source": "ghsa", "url": "https://github.com/advisories/GHSA-qj64-jj84-w38j", "first_seen_at": "2026-11-03T21:24:57+00:00"}, {"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-56091", "first_seen_at": "2026-11-03T22:07:19+00:00"}]
---

# Apache Shiro shiro-guice module vulnerable to authentication bypass

The shiro-guice module of Apache Shiro can be bypassed by a specially crafted HTTP request in a web servlet context. An attacker can reach protected pages without logging in.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- maven:org.apache.shiro:shiro-guice affected >= 2.0.0, < 3.0.0 fixed 3.0.0

## How to check

- Check whether the project depends on `org.apache.shiro:shiro-guice` (for example in `pom.xml` or the Maven dependency tree).
- Confirm the resolved version of `shiro-guice` is between `2.0.0` and `3.0.0` (exclusive of `3.0.0`).
- Note that `3.0.0-alpha-1` is affected only when shiro-guice is used in a web servlet context.

## Fix

- Upgrade `org.apache.shiro:shiro-guice` to `3.0.0` or later.

## Timeline

- 2026-11-03T21:24:57+00:00 ghsa https://github.com/advisories/GHSA-qj64-jj84-w38j
- 2026-11-03T22:07:19+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-56091

## Documents

- [fix] Patch: github.com https://github.com/apache/shiro/commit/42aa34467ad30f085fc8e003042db0c397fe8d57

## From the sources

When using Apache Shiro with the shiro-guice module in a web servlet context, a specially crafted HTTP request may cause an authentication bypass.
This vulnerability is similar to  https://www.cve.org/CVERecord?id=CVE-2020-1957 https://www.cve.org/CVERecord , except that it affects the `shiro-guice` module instead of the `shiro-spring` module.

This issue affects all Apache Shiro versions through 2.x, and 3.0.0-alpha-1 only when using `shiro-guice` module in a web servlet context.

Upgrade to version 3.0.0 or later, which fixes the issue.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
