{"id":"CVE-2026-54859","kind":"vulnerability","aliases":["CVE-2026-54859"],"related":[],"title":"Preservation WordPress plugin: unauthenticated PHP object injection lets attackers run code","description":"Unauthenticated PHP Object Injection in Preservation <= 1.15 versions.","summary":"The Preservation WordPress theme (not a plugin), versions 1.15 and earlier, deserializes untrusted data without authentication. Patchstack rates it CVSS 9.8 and says no official patch exists; the exact entry point is not published.","severity":"critical","cvss":9.8,"epss":null,"exploited":false,"exploited_at":null,"products":[{"name":"preservation","fixed":[],"affected":"<= 1.15","ecosystem":"wordpress-theme"}],"ecosystems":[],"tags":["package","php","preservation","theme","unauthenticated","wordpress"],"not_affected_if":["managed-hosting-with-patchstack-rule","plugin-not-installed","theme-not-installed"],"how_to_check":"In WordPress admin go to Appearance > Themes and check the Preservation theme version; 1.15 or earlier (active or merely installed) is vulnerable. With WP-CLI: wp theme list","fix":null,"status":"open","published_at":"2026-10-29T16:18:10+00:00","first_seen_at":"2026-10-29T16:25:59+00:00","triaged_at":"2026-10-29T16:27:38+00:00","updated_at":"2026-10-29T16:32:50+00:00","category":"package","confidence":0.7,"triage":{"at":"2026-10-29T16:27:38Z","model":"claude-haiku-5-5","output":{"fix":"unknown","reach":"internet","title":"Preservation WordPress plugin: unauthenticated PHP object injection lets attackers run code","impact":"high","summary":"Preservation, versions 1.15 and earlier, deserializes untrusted PHP objects without authentication. An attacker who sends a crafted request can trigger object injection, which can lead to code execution on the server.","audience":"businesses","category":"package","nicknames":[],"who_cares":["wordpress","php","preservation"],"confidence":0.6,"fix_status":"unknown","needs_auth":"no","worst_case":"Attacker runs code on the server via crafted object injection","analyst_note":"Confirm the affected product (plugin vs. other Preservation software), the fixed version and the vulnerable entry point via the NVD page: https://nvd.nist.gov/vuln/detail/CVE-2026-54859","how_to_check":"- Check the installed Preservation plugin version against the vulnerable range `<= 1.15`\n- unknown","plain_action":"","needs_analyst":true,"not_affected_if":["plugin-not-installed"],"who_is_affected":"Sites running the Preservation plugin at version 1.15 or earlier are exposed, since the flaw needs no login. Sites without this plugin, or running a newer version than the affected range, are not affected. The sources do not state a fixed version or a workaround.","user_interaction":"no","needs_special_setup":"unknown","severity_if_unknown":"critical"},"cost_usd":0.00066,"input_tokens":4047,"output_tokens":510,"severity_before":"critical"},"analyst_status":"done","analyst_note":"Confirm the affected product (plugin vs. other Preservation software), the fixed version and the vulnerable entry point via the NVD page: https://nvd.nist.gov/vuln/detail/CVE-2026-54859","search":"'-2026':13A,16A '-54859':14A,17A '1.15':33B,65C '9.8':45B 'attack':9A 'authent':40B 'code':11A 'cve':12A,15A 'cvss':44B 'data':38B 'deseri':36B 'earlier':35B 'entri':54B 'exact':53B 'exist':51B 'inject':7A,62C 'let':8A 'object':6A,61C 'offici':49B 'packag':19B 'patch':50B 'patchstack':41B 'php':5A,20B,60C 'plugin':3A,31B 'point':55B 'preserv':1A,21B,26B,64C 'preservation':18A 'publish':58B 'rate':42B 'run':10A 'say':47B 'theme':22B,28B 'unauthent':4A,23B,59C 'untrust':37B 'version':32B,66C 'without':39B 'wordpress':2A,24B,27B","nicknames":[],"mitigations":[],"who_affected":"Sites running the Preservation plugin at version 1.15 or earlier are exposed, since the flaw needs no login. Sites without this plugin, or running a newer version than the affected range, are not affected. The sources do not state a fixed version or a workaround.","tier":"B","verified":{},"analyst_revisit_at":null,"fix_status":"none","audience":"businesses","plain_action":null,"first_public_at":"2026-10-29T16:18:10+00:00","kev":null,"cvss_vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","cvss_by":"audit@patchstack.com","poc_count":0,"sources":[{"source":"nvd","external_id":"CVE-2026-54859","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-54859","severity":null,"published_at":"2026-10-29T16:18:10+00:00","modified_at":"2026-10-29T16:20:19+00:00","first_seen_at":"2026-10-29T16:25:59+00:00","fetched_at":"2026-10-29T16:25:59+00:00","note":null},{"source":"analyst","external_id":"CVE-2026-54859:1058","url":null,"severity":null,"published_at":"2026-10-29T16:32:50+00:00","modified_at":"2026-10-29T16:32:50+00:00","first_seen_at":"2026-10-29T16:32:50+00:00","fetched_at":"2026-10-29T16:32:50+00:00","note":"NVD page returned empty; triage said plugin but Patchstack page (reported by johska, 13 Oct 2026) shows it is a theme, <= 1.15, no official patch, Patchstack virtual-patch rule exists for its customers. Not vendor page, so nothing marked verified. No exploitation or PoC found; did not search social."}],"documents":[{"id":17757,"url":"https://patchstack.com/database/wordpress/theme/preservation/vulnerability/wordpress-preservation-theme-1-15-php-object-injection-vulnerability","title":"Patchstack: WordPress Preservation Theme <= 1.15 PHP Object Injection","kind":"advisory","source":"analyst","publisher":null,"text":null,"published_at":null,"relation":"advisory","confidence":null,"note":null}],"notice":"Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai"}