---
id: "CVE-2026-49877"
kind: "vulnerability"
aliases: ["CVE-2026-49877", "GHSA-f892-4h9f-j7g9"]
title: "Apache ActiveMQ Improper Authorization vulnerability"
severity: "high"
cvss: 8.1
epss: 0.00513
exploited: false
status: "open"
category: "package"
products: [{"name": "org.apache.activemq:apache-activemq", "fixed": ["5.19.8"], "affected": "< 5.19.8", "ecosystem": "maven"}, {"name": "org.apache.activemq:apache-activemq", "fixed": ["6.2.7"], "affected": ">= 6.0.0, < 6.2.7", "ecosystem": "maven"}, {"name": "apache activemq", "fixed": ["5.19.8"], "affected": "< 5.19.8", "ecosystem": "vendor"}, {"name": "apache activemq", "fixed": ["6.2.7"], "affected": ">= 6.0.0, < 6.2.7", "ecosystem": "vendor"}]
ecosystems: ["maven", "vendor"]
tags: ["activemq", "cwe-285", "java", "jetty", "package", "self-hosted"]
not_affected_if: ["admin-only-users", "fixed-version", "no-web-console"]
published_at: "2026-06-30T11:16:29+00:00"
first_seen_at: "2026-11-04T15:58:41+00:00"
updated_at: "2026-11-04T16:28:16+00:00"
sources: [{"source": "ghsa", "url": "https://github.com/advisories/GHSA-f892-4h9f-j7g9", "first_seen_at": "2026-11-04T15:58:41+00:00"}, {"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-49877", "first_seen_at": "2026-11-04T16:28:16+00:00"}]
---

# Apache ActiveMQ Improper Authorization vulnerability

Apache ActiveMQ's default Jetty settings did not restrict /admin/* paths in the Web Console to administrators. An authenticated low-privilege web console user can therefore reach administrative pages they should not see.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- maven:org.apache.activemq:apache-activemq affected < 5.19.8 fixed 5.19.8
- maven:org.apache.activemq:apache-activemq affected >= 6.0.0, < 6.2.7 fixed 6.2.7
- vendor:apache activemq affected < 5.19.8 fixed 5.19.8
- vendor:apache activemq affected >= 6.0.0, < 6.2.7 fixed 6.2.7

## How to check

- Check the ActiveMQ version with `activemq --version` or the version in the broker's lib directory, and compare it with the affected ranges.
- Confirm whether the Web Console is enabled on the broker and whether low-privilege user accounts exist in its authentication configuration.

## Fix

- Apache ActiveMQ `5.19.8` for the 5.x line (affected before 5.19.8)
- Apache ActiveMQ `6.2.7` for the 6.x line (affected from 6.0.0 before 6.2.7)

## Timeline

- 2026-11-04T15:58:41+00:00 ghsa https://github.com/advisories/GHSA-f892-4h9f-j7g9
- 2026-11-04T16:28:16+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-49877

## Documents

- [advisory] Vendor advisory: lists.apache.org https://lists.apache.org/thread/w82vtc3q02j5ot94tnyy1197y3wb98hl
- [advisory] Third-party advisory: www.openwall.com http://www.openwall.com/lists/oss-security/2026/06/29/9
- [fix] Patch: github.com https://github.com/apache/activemq/commit/1eda6a164f38b6eb1a90ffb1462a95cd9ad121e9
- [fix] Patch: github.com https://github.com/apache/activemq/commit/be70a7efa1efcb6bdb9988f736245b06d39a91e4
- [fix] Patch: github.com https://github.com/apache/activemq/pull/2074
- [fix] Release: github.com https://github.com/apache/activemq/releases/tag/activemq-6.2.7
- [fix] Release: github.com https://github.com/apache/activemq/releases/tag/activemq-5.19.8
- [fix] Patch: github.com https://github.com/apache/activemq/commit/085efea55270aca20f2158c0a91a0f4a9fe497f4

## From the sources

Improper Authorization vulnerability in Apache ActiveMQ.

An authenticated low-privilege Web Console user by default can access /admin/* paths in the Web Console. The default Jetty settings incorrectly did not limit those paths to only admins.
This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7.

Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
