---
id: "CVE-2026-49432"
kind: "vulnerability"
aliases: ["CVE-2026-49432", "GHSA-xjwq-9jw5-jf7w"]
title: "Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp has an Improper Input Validation vulnerability"
severity: "high"
cvss: 7.5
epss: 0.00785
exploited: false
status: "open"
category: "package"
products: [{"name": "org.apache.activemq:apache-activemq", "fixed": ["5.19.8"], "affected": "< 5.19.8", "ecosystem": "maven"}, {"name": "org.apache.activemq:apache-activemq", "fixed": ["6.2.7"], "affected": ">= 6.0.0, < 6.2.7", "ecosystem": "maven"}, {"name": "org.apache.activemq:activemq-all", "fixed": ["5.19.8"], "affected": "< 5.19.8", "ecosystem": "maven"}, {"name": "org.apache.activemq:activemq-all", "fixed": ["6.2.7"], "affected": ">= 6.0.0, < 6.2.7", "ecosystem": "maven"}, {"name": "org.apache.activemq:activemq-stomp", "fixed": ["5.19.8"], "affected": "< 5.19.8", "ecosystem": "maven"}, {"name": "org.apache.activemq:activemq-stomp", "fixed": ["6.2.7"], "affected": ">= 6.0.0, < 6.2.7", "ecosystem": "maven"}, {"name": "apache activemq", "fixed": ["5.19.8"], "affected": "< 5.19.8", "ecosystem": "vendor"}, {"name": "apache activemq", "fixed": ["6.2.7"], "affected": ">= 6.0.0, < 6.2.7", "ecosystem": "vendor"}]
ecosystems: ["maven", "vendor"]
tags: ["activemq", "cwe-20", "cwe-839", "java", "message-broker", "package", "stomp"]
not_affected_if: ["internal-network-only", "stomp-connector-disabled"]
published_at: "2026-06-30T11:16:29+00:00"
first_seen_at: "2026-11-05T17:38:59+00:00"
updated_at: "2026-11-05T17:40:05+00:00"
sources: [{"source": "ghsa", "url": "https://github.com/advisories/GHSA-xjwq-9jw5-jf7w", "first_seen_at": "2026-11-05T17:38:59+00:00"}, {"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-49432", "first_seen_at": "2026-11-05T17:40:05+00:00"}]
exploit_sources: [{"type": "epss", "score": 0.00785, "url": "https://api.first.org/data/v1/epss?cve=CVE-2026-49432"}]
---

# Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp has an Improper Input Validation vulnerability

A negative content-length in a STOMP frame can make the ActiveMQ STOMP connector exhaust memory on the NIO transport or drop the connection on the blocking transport. An unauthenticated remote peer that can reach the STOMP connector can cause denial of service.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- maven:org.apache.activemq:apache-activemq affected < 5.19.8 fixed 5.19.8
- maven:org.apache.activemq:apache-activemq affected >= 6.0.0, < 6.2.7 fixed 6.2.7
- maven:org.apache.activemq:activemq-all affected < 5.19.8 fixed 5.19.8
- maven:org.apache.activemq:activemq-all affected >= 6.0.0, < 6.2.7 fixed 6.2.7
- maven:org.apache.activemq:activemq-stomp affected < 5.19.8 fixed 5.19.8
- maven:org.apache.activemq:activemq-stomp affected >= 6.0.0, < 6.2.7 fixed 6.2.7
- vendor:apache activemq affected < 5.19.8 fixed 5.19.8
- vendor:apache activemq affected >= 6.0.0, < 6.2.7 fixed 6.2.7

## How to check

- Check the ActiveMQ version in use with the Maven dependency `org.apache.activemq:apache-activemq`, `activemq-all` or `activemq-stomp`.
- Check whether a STOMP transport connector is enabled and reachable from untrusted networks in the broker configuration.

## Fix

- Upgrade `org.apache.activemq` 5.x to `5.19.8`.
- Upgrade `org.apache.activemq` 6.x to `6.2.7`.

## Timeline

- 2026-11-05T17:38:59+00:00 ghsa https://github.com/advisories/GHSA-xjwq-9jw5-jf7w
- 2026-11-05T17:40:05+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-49432

## Documents

- [advisory] Vendor advisory: lists.apache.org https://lists.apache.org/thread/fsjb26605syqr8xks249h8gkp86t55d2
- [advisory] Third-party advisory: www.openwall.com http://www.openwall.com/lists/oss-security/2026/06/29/7
- [fix] Patch: github.com https://github.com/apache/activemq/commit/63ca7332a47239964cbf2e343603412254ebb358
- [fix] Patch: github.com https://github.com/apache/activemq/commit/713cae920329c4caea016b08300182ec5c6dc99b
- [fix] Patch: github.com https://github.com/apache/activemq/pull/2064
- [fix] Release: github.com https://github.com/apache/activemq/releases/tag/activemq-6.2.7
- [fix] Release: github.com https://github.com/apache/activemq/releases/tag/activemq-5.19.8
- [fix] Patch: github.com https://github.com/apache/activemq/commit/1493db95b5918d4f4a305fd1df8155f57c38850b

## From the sources

Improper Input Validation vulnerability in Apache ActiveMQ, Apache ActiveMQ All, Apache ActiveMQ Stomp.

A remote unauthenticated peer that can reach an exposed STOMP connector can trigger denial-of-service behavior by sending a negative content-length. For the NIO STOMP transport, an attacker can keep streaming body bytes and grow the per-connection command buffer beyond configured limits to cause OOM. For the blocking STOMP protocol, an error will instead force abnormal transport exception handling for the affected connection and closure.
This issue affects Apache ActiveMQ: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ All: before 5.19.8, from 6.0.0 before 6.2.7; Apache ActiveMQ Stomp: before 5.19.8, from 6.0.0 before 6.2.7.




Users are recommended to upgrade to version 6.2.7 or 5.19.8, which fixes the issue.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
