---
id: "CVE-2026-45048"
kind: "vulnerability"
aliases: ["CVE-2026-45048", "GHSA-vvhj-w2jq-263q"]
title: "OpenAM Authenticated Privilege Escalation via Raw Token Disclosure Session RPC"
severity: "high"
cvss: 8.5
epss: 0.00428
exploited: false
status: "open"
category: "package"
products: [{"name": "org.openidentityplatform.openam:openam-core", "fixed": ["16.1.1"], "affected": "<= 16.0.6", "ecosystem": "maven"}]
ecosystems: ["maven"]
tags: ["cwe-200", "cwe-285", "identity", "maven", "openam", "package", "self-hosted"]
not_affected_if: ["patched-16.1.1-or-later"]
published_at: "2026-06-23T17:33:00+00:00"
first_seen_at: "2026-10-28T15:29:40+00:00"
updated_at: "2026-10-28T15:30:54+00:00"
sources: [{"source": "ghsa", "url": "https://github.com/advisories/GHSA-vvhj-w2jq-263q", "first_seen_at": "2026-10-28T15:29:40+00:00"}, {"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-45048", "first_seen_at": "2026-10-28T15:33:37+00:00"}]
---

# OpenAM Authenticated Privilege Escalation via Raw Token Disclosure Session RPC

OpenAM Community Edition's session management endpoint does not check ownership or privilege when querying sessions, so any logged-in user can retrieve raw session credentials of other accounts. Taking over a higher-privileged session can lead to administrative actions on the platform.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- maven:org.openidentityplatform.openam:openam-core affected <= 16.0.6 fixed 16.1.1

## How to check

- Check the openam-core version in the Maven dependency tree, for example `mvn dependency:tree | grep openam-core`
- Confirm whether stateful session storage is in use and whether the session management endpoint is reachable, per the deployment configuration (unknown in the sources beyond this)

## Fix

- Upgrade `openam-core` to `16.1.1` or later, the version the advisory names as patched

## Timeline

- 2026-10-28T15:29:40+00:00 ghsa https://github.com/advisories/GHSA-vvhj-w2jq-263q
- 2026-10-28T15:33:37+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-45048

## From the sources

## Summary

Description

An insufficient authorization (CWE-285) and information exposure (CWE-200) issue in OpenAM's session management endpoint allows a low-privileged authenticated user to retrieve active session credentials belonging to other users, including those with higher privileges. This affects OpenAM Community Edition through version 16.0.6 and was patched in version 16.1.1.

This may be related to CVE-2021-4201, a similar issue patched in ForgeRock Access Management, a separate product sharing a common codebase ancestry.

## Impact

OpenAM Community Edition deployments through version 16.0.6 using stateful session storage and exposing the session management endpoint are potentially affected. The endpoint does not enforce ownership or privilege checks when querying session information, meaning an authenticated user may retrieve active session credentials for arbitrary users. Successful exploitation requires a valid low-privilege session and knowledge of a target user's identity identifier, which may be obtainable through normal platform functionality.

If credentials belonging to a highly privileged account are obtained, this could enable further administrative actions within the platform

## Patch

This has been patched in OpenAM Community Edition version 16.1.1. Users are encouraged to update to the latest release.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
