---
id: "CVE-2026-41603"
kind: "vulnerability"
aliases: ["CVE-2026-41603", "GHSA-gf47-qgg5-9g9q"]
title: "Apache Thrift has an issue with Java TSSLTransportFactory hostname verification"
severity: "high"
cvss: 7.4
epss: 0.00571
exploited: false
status: "withdrawn"
category: "package"
products: [{"name": "org.apache.thrift:libthrift", "fixed": ["0.23.0"], "affected": "< 0.23.0", "ecosystem": "maven"}]
ecosystems: ["maven"]
tags: ["apache-thrift", "cwe-295", "cwe-297", "java", "maven", "package", "tls"]
not_affected_if: ["libthrift-0.23.0-or-later", "non-java-thrift", "plaintext-transport"]
published_at: "2026-04-28T10:16:03+00:00"
first_seen_at: "2026-10-28T19:51:20+00:00"
updated_at: "2026-10-28T20:05:07+00:00"
sources: [{"source": "ghsa", "url": "https://github.com/advisories/GHSA-gf47-qgg5-9g9q", "first_seen_at": "2026-10-28T19:51:20+00:00"}, {"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-41603", "first_seen_at": "2026-10-28T20:05:07+00:00"}]
---

# Apache Thrift has an issue with Java TSSLTransportFactory hostname verification

The Java TSSLTransportFactory in Apache Thrift does not properly verify that a server certificate matches the host being connected to. An attacker positioned on the network path can present any valid-looking certificate and intercept the Thrift traffic.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- maven:org.apache.thrift:libthrift affected < 0.23.0 fixed 0.23.0

## How to check

- Run `mvn dependency:tree | grep libthrift` in the project and look for a version below `0.23.0`
- Check for `org.apache.thrift:libthrift` in `build.gradle` or `pom.xml` and confirm the pinned version

## Fix

- Upgrade `org.apache.thrift:libthrift` to `0.23.0` or later
- Rebuild and redeploy services that link against libthrift

## Timeline

- 2026-10-28T19:51:20+00:00 ghsa https://github.com/advisories/GHSA-gf47-qgg5-9g9q
- 2026-10-28T20:05:07+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-41603

## From the sources

Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift.

This issue affects Apache Thrift: before 0.23.0.

Users are recommended to upgrade to version 0.23.0, which fixes the issue.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
