{"id":"CVE-2026-39737","kind":"vulnerability","aliases":["CVE-2026-39737"],"related":[],"title":"JetElements for Elementor: stored XSS lets attackers run scripts in pages","description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Crocoblock JetElements For Elementor jet-elements allows Stored XSS.This issue affects JetElements For Elementor: from n/a through 2.9.2.6.","summary":"JetElements For Elementor, a WordPress plugin from Crocoblock, fails to neutralize input when generating web pages, allowing stored cross-site scripting. An attacker who can save crafted content can run scripts in other visitors' browsers, including administrators.","severity":"medium","cvss":6.5,"epss":null,"exploited":false,"exploited_at":null,"products":[],"ecosystems":[],"tags":["elementor","jetelements","package","wordpress"],"not_affected_if":["plugin-not-installed","trusted-editors-only"],"how_to_check":"- Check the installed JetElements For Elementor plugin version in the WordPress admin plugins list or the `jet-elements` plugin header.\n- Compare the installed version against the affected range: from n/a through `2.9.2.6`.","fix":null,"status":"open","published_at":"2026-10-29T15:17:22+00:00","first_seen_at":"2026-10-29T15:25:39+00:00","triaged_at":"2026-10-29T15:26:35+00:00","updated_at":"2026-10-29T15:26:35+00:00","category":"package","confidence":0.5,"triage":{"at":"2026-10-29T15:26:35Z","model":"claude-haiku-5-5","output":{"fix":"unknown","reach":"internet","title":"JetElements for Elementor: stored XSS lets attackers run scripts in pages","impact":"medium","summary":"JetElements For Elementor, a WordPress plugin from Crocoblock, fails to neutralize input when generating web pages, allowing stored cross-site scripting. An attacker who can save crafted content can run scripts in other visitors' browsers, including administrators.","audience":"businesses","category":"package","nicknames":[],"who_cares":["wordpress","elementor","jetelements"],"confidence":0.5,"fix_status":"unknown","needs_auth":"unknown","worst_case":"Scripts run in visitors' browsers, possibly stealing admin sessions.","analyst_note":"Confirm the patched version after 2.9.2.6 and whether authentication is required, using the NVD entry and the Crocoblock or WordPress plugin changelog.","how_to_check":"- Check the installed JetElements For Elementor plugin version in the WordPress admin plugins list or the `jet-elements` plugin header.\n- Compare the installed version against the affected range: from n/a through `2.9.2.6`.","plain_action":"","needs_analyst":true,"not_affected_if":["plugin-not-installed","trusted-editors-only"],"who_is_affected":"Sites running the JetElements For Elementor plugin (`jet-elements`) at version `2.9.2.6` or earlier, where Elementor is used to build pages. The flaw needs a way for content to be stored, so sites where only trusted editors can write content have lower exposure. Sites that do not run this plugin can skip it.","user_interaction":"unknown","needs_special_setup":"unknown","severity_if_unknown":"medium"},"cost_usd":0.00071,"input_tokens":4127,"output_tokens":595,"severity_before":"medium"},"analyst_status":null,"analyst_note":null,"search":"'-2026':13A,16A '-39737':14A,17A '2.9.2.6':92C 'administr':59B 'affect':85C 'allow':38B,81C 'attack':7A,45B 'browser':57B 'content':50B 'craft':49B 'crocoblock':29B,74C 'cross':41B,69C 'cross-sit':40B,68C 'cve':12A,15A 'element':80C 'elementor':3A,18B,24B,77C,88C 'fail':30B 'generat':35B,67C 'improp':60C 'includ':58B 'input':33B,63C 'issu':84C 'jet':79C 'jet-el':78C 'jetel':1A,19B,22B,75C,86C 'let':6A 'n/a':90C 'neutral':32B,61C 'packag':20B 'page':11A,37B,66C 'plugin':27B 'run':8A,52B 'save':48B 'script':9A,43B,53B,71C 'site':42B,70C 'store':4A,39B,82C 'visitor':56B 'vulner':72C 'web':36B,65C 'wordpress':21B,26B 'xss':5A 'xss.this':83C","nicknames":[],"mitigations":[],"who_affected":"Sites running the JetElements For Elementor plugin (`jet-elements`) at version `2.9.2.6` or earlier, where Elementor is used to build pages. The flaw needs a way for content to be stored, so sites where only trusted editors can write content have lower exposure. Sites that do not run this plugin can skip it.","tier":"C","verified":{},"analyst_revisit_at":null,"fix_status":"none","audience":"businesses","plain_action":null,"first_public_at":"2026-10-29T15:17:22+00:00","kev":null,"cvss_vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L","cvss_by":"audit@patchstack.com","poc_count":0,"sources":[{"source":"nvd","external_id":"CVE-2026-39737","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-39737","severity":null,"published_at":"2026-10-29T15:17:22+00:00","modified_at":"2026-10-29T15:18:54+00:00","first_seen_at":"2026-10-29T15:25:39+00:00","fetched_at":"2026-10-29T15:25:39+00:00","note":null}],"documents":[],"notice":"Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai"}