---
id: "CVE-2026-28160"
kind: "vulnerability"
aliases: ["CVE-2026-28160"]
title: "VikRentCar WordPress plugin: unauthenticated XSS through an unknown input"
severity: "high"
cvss: 7.1
epss: null
exploited: false
status: "open"
category: "package"
products: [{"name": "vikrentcar", "fixed": [], "affected": "<= 1.4.10", "ecosystem": "wordpress"}]
ecosystems: []
tags: ["package", "rental-sites", "vikrentcar", "wordpress"]
not_affected_if: ["plugin-not-installed"]
published_at: "2026-10-30T19:18:23+00:00"
first_seen_at: "2026-10-30T19:25:29+00:00"
updated_at: "2026-10-30T19:30:04+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-28160", "first_seen_at": "2026-10-30T19:25:29+00:00"}, {"source": "analyst", "url": null, "first_seen_at": "2026-10-30T19:30:04+00:00"}]
---

# VikRentCar WordPress plugin: unauthenticated XSS through an unknown input

VikRentCar, a WordPress plugin for vehicle rental sites, has a cross-site scripting flaw in versions 1.4.10 and earlier. An anonymous visitor can inject script that runs in other users' browsers.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- wordpress:vikrentcar affected <= 1.4.10 fixed ?

## How to check

In WordPress admin under Plugins, check the VikRentCar version; 1.4.10 or earlier is listed as affected. Or run: wp plugin get vikrentcar --field=version

## Fix

Update VikRentCar to the latest release (1.4.11 is current per Patchstack). Not confirmed by the vendor as the fix for this specific CVE.

## Timeline

- 2026-10-30T19:25:29+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-28160
- 2026-10-30T19:30:04+00:00 analyst — NVD page unreadable; no primary advisory found tying this CVE to a specific input. Patchstack (CNA) lists VikRentCar <=1.4.10 with 1.4.11 as latest release, but its 1.4.10 entries are Contributor+ stored XSS/SQLi, not unauthenticated, so mapping to this CVE is unconfirmed. Siblings: CVE-2026-39790 (fixed 1.4.8), CVE-2026-112835/112838 (<=1.4.8), CVE-2026-116749 (className, fixed 1.4.11). Nothing verified; no PoC or exploitation found.

## Documents

- [mentions] VikRentCar plugin page (WordPress.org) https://wordpress.org/plugins/vikrentcar/
- [mentions] Patchstack: VikRentCar vulnerability history (latest 1.4.11) https://patchstack.com/database/wordpress/plugin/vikrentcar/vulnerabilities

## From the sources

Unauthenticated Cross Site Scripting (XSS) in VikRentCar <= 1.4.10 versions.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
