---
id: "CVE-2026-17319"
page: "https://infrastack.ai/live/CVE-2026-17319"
kind: "vulnerability"
aliases: ["CVE-2026-17319"]
title: "IBM API Connect V12 OnPrem 12.1.0.0\u201312.1.1.2: authenticated user can change tool settings and cause denial of service; fixed in 12.1.1.3"
severity: "high"
cvss: 7.1
epss: null
exploited: false
status: "open"
category: "infrastructure"
products: [{"name": "API Connect V12 OnPrem", "fixed": ["12.1.1.3"], "affected": ">= 12.1.0.0, <= 12.1.1.2", "ecosystem": "vendor"}]
ecosystems: []
tags: ["api-gateway", "authenticated", "ibm-api-connect", "infrastructure", "self-hosted"]
not_affected_if: ["auth-required", "outside-affected-range", "version-outside-range"]
published_at: "2026-11-07T05:18:41+00:00"
first_seen_at: "2026-11-07T05:46:03+00:00"
updated_at: "2026-11-07T06:18:36+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-17319", "first_seen_at": "2026-11-07T05:46:03+00:00"}, {"source": "analyst", "url": "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39", "first_seen_at": "2026-11-07T06:18:36+00:00", "cites": ["https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39"]}]
exploit_sources: []
---

# IBM API Connect V12 OnPrem 12.1.0.0–12.1.1.2: authenticated user can change tool settings and cause denial of service; fixed in 12.1.1.3

Link for people: https://infrastack.ai/live/CVE-2026-17319 (this .md is for agents)

IBM says API Connect could let a remote authenticated attacker modify tool configuration and cause a denial of service, because client-supplied information is relied on when deciding what a user may do (CWE-862, CVSS 7.1, vector AV:A/AC:H/PR:L, adjacent network). Affects API Connect V12 OnPrem v12.1.0.0-v12.1.1.2; fixed in v12.1.1.3. IBM lists no workarounds. No exploitation or PoC stated.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:API Connect V12 OnPrem affected >= 12.1.0.0, <= 12.1.1.2 fixed 12.1.1.3

## How to check

Check your API Connect V12 OnPrem version. v12.1.0.0 through v12.1.1.2 is affected; v12.1.1.3 is fixed. IBM does not name the vulnerable component or role. Also check if you run other API Connect lines: IBM's bulletin lists only V12 OnPrem for this CVE.

## Fix

Upgrade IBM API Connect V12 OnPrem to v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205). IBM lists no workarounds.

## Timeline

- 2026-11-07T05:46:03+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-17319
- 2026-11-07T06:18:36+00:00 analyst https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39 — Read IBM bulletin node -39 (2026-11-05): CVE-2026-17319 listed, CWE-862, CVSS 7.1; affected v12.1.0.0-v12.1.1.2, fixed v12.1.1.3, no workarounds. No exploitation/PoC stated; Feedly page claims were not used.

## Documents

- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (v12.1.1.3) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39

## From the sources

IBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to modify tool configuration and cause a denial of service due to improper authorization. Information supplied by the client is relied on when deciding what a user is allowed to do, which could allow unauthorized changes that disrupt service.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
