CVE-2026-17304 · Vendor
NO FIX YET · SEE WHAT TO DO
IBM API Connect 12.1.0.0 through 12.1.1.2 does not validate locations supplied when service definitions are imported. An authenticated remote attacker can make the server fetch content it should not access, which exposes sensitive information.
first public Nov 7, 2026 · 1 source
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Organizations running IBM API Connect 12.1.0.0 through 12.1.1.2 where users can import service definitions. The flaw needs an authenticated account able to import definitions, so teams that restrict imports to trusted administrators have less exposure. unknown for further detail.
Not affected if auth-required, version-outside-range
Who cares api-gateway, ibm-api-connect, self-hosted
12.1.0.0 through 12.1.1.212.1.1.2; the sources do not name the fixed versionIBM API Connect 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to improper input validation. Locations supplied when service definitions are imported are not sufficiently validated, which could allow the server to retrieve content it should not access.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.