---
id: "CVE-2026-17147"
page: "https://infrastack.ai/live/CVE-2026-17147"
kind: "vulnerability"
aliases: ["CVE-2026-17147"]
title: "IBM API Connect V12 OnPrem: path traversal lets authenticated user run code"
severity: "critical"
cvss: 9.9
epss: null
exploited: false
status: "open"
category: "vendor"
products: [{"name": "API Connect V12 OnPrem", "fixed": ["12.1.1.3"], "affected": ">= 12.1.0.0, <= 12.1.1.2", "ecosystem": "vendor"}]
ecosystems: []
tags: ["api-gateway", "ibm-api-connect", "self-hosted", "vendor"]
not_affected_if: []
published_at: "2026-11-07T05:18:28+00:00"
first_seen_at: "2026-11-07T05:45:59+00:00"
updated_at: "2026-11-07T05:59:22+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-17147", "first_seen_at": "2026-11-07T05:45:59+00:00"}, {"source": "analyst", "url": "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39", "first_seen_at": "2026-11-07T05:59:22+00:00", "cites": ["https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39"]}]
exploit_sources: []
---

# IBM API Connect V12 OnPrem: path traversal lets authenticated user run code

Link for people: https://infrastack.ai/live/CVE-2026-17147 (this .md is for agents)

IBM API Connect versions 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 contain a path traversal flaw. A remote attacker with a valid account can execute arbitrary code and perform unauthorized administrative actions.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:API Connect V12 OnPrem affected >= 12.1.0.0, <= 12.1.1.2 fixed 12.1.1.3

## How to check

Check your API Connect V12 OnPrem version: affected if it is v12.1.0.0 through v12.1.1.2. Also check any 10.0.8.x install (10.0.8.0-10.0.8.12), which NVD lists but IBM's bulletin for this CVE does not confirm.

## Fix

Upgrade API Connect V12 OnPrem to v12.1.1.3 (Fix Central: https://www.ibm.com/support/pages/node/7290205). IBM lists no workarounds.

## Timeline

- 2026-11-07T05:45:59+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-17147
- 2026-11-07T05:59:22+00:00 analyst https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39 — IBM bulletin (-39, 2026-11-05) lists CVE-2026-17147 (CWE-22, CVSS 9.9) under API Connect V12 OnPrem v12.1.0.0-v12.1.1.2, fix v12.1.1.3, no workarounds. The 10.0.8.0-10.0.8.12 range from NVD is not in this bulletin; the 10.0.8.13 bulletin (-38) does not list this CVE, so 10.0.8 is unconfirmed. No exploitation or PoC found; not searched on X.

## Documents

- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (v12.1.1.3) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39

## From the sources

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to execute arbitrary code and perform unauthorized administrative actions due to a path traversal vulnerability.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
