---
id: "CVE-2026-16718"
page: "https://infrastack.ai/live/CVE-2026-16718"
kind: "vulnerability"
aliases: ["CVE-2026-16718"]
title: "IBM API Connect 10.0.8.0-10.0.8.12 and 12.1.0.0-12.1.1.2: authenticated path traversal exposes sensitive information; fixed in 10.0.8.13 and 12.1.1.3"
severity: "high"
cvss: 7.7
epss: null
exploited: false
status: "open"
category: "infrastructure"
products: [{"name": "API Connect", "fixed": ["10.0.8.13"], "affected": "10.0.8.0 - 10.0.8.12", "ecosystem": "vendor"}, {"name": "API Connect V12", "fixed": ["12.1.1.3"], "affected": "12.1.0.0 - 12.1.1.2", "ecosystem": "vendor"}]
ecosystems: []
tags: ["api-gateway", "ibm-api-connect", "infrastructure", "self-hosted"]
not_affected_if: ["unaffected-version", "versions-outside-affected-ranges"]
published_at: "2026-11-07T05:18:21+00:00"
first_seen_at: "2026-11-07T05:45:57+00:00"
updated_at: "2026-11-07T06:26:12+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-16718", "first_seen_at": "2026-11-07T05:45:57+00:00"}, {"source": "analyst", "url": "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41", "first_seen_at": "2026-11-07T06:26:12+00:00", "cites": ["https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41", "https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39"]}]
exploit_sources: []
---

# IBM API Connect 10.0.8.0-10.0.8.12 and 12.1.0.0-12.1.1.2: authenticated path traversal exposes sensitive information; fixed in 10.0.8.13 and 12.1.1.3

Link for people: https://infrastack.ai/live/CVE-2026-16718 (this .md is for agents)

IBM API Connect 10.0.8.0-10.0.8.12 and 12.1.0.0-12.1.1.2 do not properly validate file paths (CWE-22). A remote authenticated attacker can read sensitive information. IBM fixed it in 10.0.8.13 and 12.1.1.3; no workaround is listed.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:API Connect affected 10.0.8.0 - 10.0.8.12 fixed 10.0.8.13
- vendor:API Connect V12 affected 12.1.0.0 - 12.1.1.2 fixed 12.1.1.3

## How to check

Check the installed API Connect version: affected are 10.0.8.0 to 10.0.8.12 and 12.1.0.0 to 12.1.1.2. Fixed in 10.0.8.13 and 12.1.1.3. IBM does not name the vulnerable endpoint.

## Fix

Upgrade API Connect 10.0.8.x to 10.0.8.13, or 12.1.x to 12.1.1.3, via IBM Fix Central. IBM lists no workaround.

## Timeline

- 2026-11-07T05:45:57+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-16718
- 2026-11-07T06:26:12+00:00 analyst https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41 — IBM bulletins -41 (10.0.8.13) and -39 (v12.1.1.3) both list CVE-2026-16718, CWE-22, CVSS 7.7. -41 table shows 10.0.8.0-10.0.8.12; V12 range from NVD/IBM CVE record. No workaround listed; endpoint not named. Only the 10.0.8 fix/check verified from -41 text; V12 table not read.

## Documents

- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (10.0.8.13) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-41
- [advisory] IBM Security Bulletin: Multiple Vulnerabilities in IBM API Connect (v12.1.1.3) https://www.ibm.com/support/pages/security-bulletin-multiple-vulnerabilities-ibm-api-connect-39

## From the sources

IBM API Connect 10.0.8.0 through 10.0.8.12 and 12.1.0.0 through 12.1.1.2 could allow a remote authenticated attacker to obtain sensitive information due to improper validation of file paths.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
