---
id: "CVE-2026-123788"
page: "https://infrastack.ai/live/CVE-2026-123788"
kind: "vulnerability"
aliases: ["CVE-2026-123788"]
title: "grok2api: STT billing voice handler flaw lets remote requests bypass workflow"
severity: "medium"
cvss: 5.3
epss: null
exploited: false
status: "open"
category: "ai-tooling"
products: []
ecosystems: []
tags: ["ai-proxy", "ai-tooling", "grok2api", "self-hosted", "speech-to-text"]
not_affected_if: ["version-3.1.7-or-later"]
published_at: "2026-11-06T22:17:50+00:00"
first_seen_at: "2026-11-06T22:44:32+00:00"
updated_at: "2026-11-06T22:44:51+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-123788", "first_seen_at": "2026-11-06T22:44:32+00:00"}]
exploit_sources: []
---

# grok2api: STT billing voice handler flaw lets remote requests bypass workflow

Link for people: https://infrastack.ai/live/CVE-2026-123788 (this .md is for agents)

grok2api is a proxy that exposes Grok models through an API, and its speech-to-text billing component has a flaw in its voice WebSocket handler. A remote attacker may be able to manipulate the billing workflow to bypass its enforcement.

_Summary, check and fix written by a model from the sources; labelled as such._

## How to check

- Check the grok2api version in your deployment; versions up to `3.1.6` are listed as affected.
- Review `backend/internal/transport/http/inference/voice_ws_handler.go` if you run a patched fork.

## Fix

- Upgrade grok2api to `3.1.7` (patch commit 7ad0f791f0a9eb5a0ddfe38ac4dfcef01e19a6d4).

## Timeline

- 2026-11-06T22:44:32+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-123788

## Documents

- [fix] Patch: github.com https://github.com/chenyme/grok2api/commit/7ad0f791f0a9eb5a0ddfe38ac4dfcef01e19a6d4
- [fix] Release notes: github.com https://github.com/chenyme/grok2api/releases/tag/v3.1.7

## From the sources

A security vulnerability has been detected in chenyme grok2api up to 3.1.6. The impacted element is an unknown function of the file backend/internal/transport/http/inference/voice_ws_handler.go of the component STT Billing. The manipulation leads to enforcement of behavioral workflow. The attack may be initiated remotely. Upgrading to version 3.1.7 is sufficient to resolve this issue. The identifier of the patch is 7ad0f791f0a9eb5a0ddfe38ac4dfcef01e19a6d4. Upgrading the affected component is recommended.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
