---
id: "CVE-2026-123023"
kind: "vulnerability"
aliases: ["CVE-2026-123023"]
title: "AgentScope: Bash tool authorization flaw lets remote users bypass permission checks"
severity: "high"
cvss: 7.5
epss: null
exploited: false
status: "open"
category: "ai-tooling"
products: []
ecosystems: []
tags: ["agentscope", "ai-agents", "ai-tooling", "bash-tool", "python"]
not_affected_if: ["bash-tool-disabled", "version-2.0.9-or-later"]
published_at: "2026-11-05T14:17:04+00:00"
first_seen_at: "2026-11-05T14:39:18+00:00"
updated_at: "2026-11-05T14:40:21+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-123023", "first_seen_at": "2026-11-05T14:39:18+00:00"}]
exploit_sources: []
---

# AgentScope: Bash tool authorization flaw lets remote users bypass permission checks

AgentScope is an agent framework, and its built-in Bash tool checks permissions incorrectly in versions up to 2.0.8. A remote attacker can exploit this, and a published exploit exists, so the agent may be made to run commands it should be blocked from running.

_Summary, check and fix written by a model from the sources; labelled as such._

## How to check

- Check the installed AgentScope version with `pip show agentscope` or the lockfile, and look for any version up to `2.0.8`.
- Look for use of the Bash tool (`src/agentscope/tool/_builtin/_bash.py`) in agents that accept input from outside users.

## Fix

- Upgrade AgentScope to `2.0.9`, per the source.

## Timeline

- 2026-11-05T14:39:18+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-123023

## Documents

- [fix] Patch: github.com https://github.com/agentscope-ai/agentscope/commit/6b43b13a46401e86abd3defeed9a8bfe5b37bc6d
- [fix] Release notes: github.com https://github.com/agentscope-ai/agentscope/releases/tag/v2.0.9

## From the sources

A flaw has been found in agentscope-ai AgentScope up to 2.0.8. This affects the function check_permissions of the file src/agentscope/tool/_builtin/_bash.py of the component Bash Tool. This manipulation causes incorrect authorization. Remote exploitation of the attack is possible. The exploit has been published and may be used. Upgrading to version 2.0.9 mitigates this issue. Patch name: 6b43b13a46401e86abd3defeed9a8bfe5b37bc6d. It is recommended to upgrade the affected component.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
