{"id":"CVE-2026-121775","kind":"vulnerability","aliases":["CVE-2026-121775"],"related":[],"title":"CURCY WooCommerce multi-currency plugin: missing authorization check","description":"Missing Authorization vulnerability in VillaTheme CURCY woo-multi-currency allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects CURCY: from n/a through 2.2.20.","summary":"The CURCY multi-currency plugin for WooCommerce, made by VillaTheme, has a missing authorization check in versions through 2.2.20. A user may be able to perform actions they should not be allowed to perform.","severity":"medium","cvss":5.3,"epss":null,"exploited":false,"exploited_at":null,"products":[],"ecosystems":[],"tags":["package","woo-multi-currency","woocommerce","wordpress"],"not_affected_if":["plugin-not-installed"],"how_to_check":"- Check the installed CURCY version (woo-multi-currency) in the WordPress plugins screen or the plugin header.\n- Compare it with the fixed version in the product data (`2.2.20` or earlier is affected per NVD).","fix":null,"status":"open","published_at":"2026-11-07T13:16:35+00:00","first_seen_at":"2026-11-07T13:47:25+00:00","triaged_at":"2026-11-07T13:49:34+00:00","updated_at":"2026-11-07T13:49:34+00:00","category":"package","confidence":0.5,"triage":{"at":"2026-11-07T13:49:34Z","model":"claude-haiku-5-5","output":{"fix":"unknown","reach":"internet","title":"CURCY WooCommerce multi-currency plugin: missing authorization check","impact":"medium","summary":"The CURCY multi-currency plugin for WooCommerce, made by VillaTheme, has a missing authorization check in versions through 2.2.20. A user may be able to perform actions they should not be allowed to perform.","audience":"businesses","category":"package","nicknames":[],"who_cares":["woocommerce","wordpress","woo-multi-currency"],"confidence":0.5,"fix_status":"unknown","needs_auth":"unknown","worst_case":"unauthorized users perform restricted plugin actions on the store","analyst_note":"Confirm the fixed version and which plugin actions lack the authorization check, using the NVD entry https://nvd.nist.gov/vuln/detail/CVE-2026-121775 and the vendor's changelog.","how_to_check":"- Check the installed CURCY version (woo-multi-currency) in the WordPress plugins screen or the plugin header.\n- Compare it with the fixed version in the product data (`2.2.20` or earlier is affected per NVD).","plain_action":"","needs_analyst":true,"not_affected_if":["plugin-not-installed"],"who_is_affected":"Sites running the CURCY (woo-multi-currency) WooCommerce plugin at version 2.2.20 or earlier. The sources do not say which actions are reachable or whether a default configuration is exposed, so the exact exposure is unknown.","user_interaction":"unknown","needs_special_setup":"unknown","severity_if_unknown":"medium"},"cost_usd":0.000701,"input_tokens":4215,"output_tokens":559,"severity_before":"medium"},"analyst_status":null,"analyst_note":null,"search":"'-121775':12A,15A '-2026':11A,14A '2.2.20':42B,82C 'abl':47B 'access':72C 'action':50B 'affect':77C 'allow':55B,68C 'author':8A,37B,59C 'check':9A,38B 'configur':71C 'control':73C 'curci':1A,24B,63C,78C 'currenc':5A,20B,27B,67C 'cve':10A,13A 'exploit':69C 'incorrect':70C 'issu':76C 'levels.this':75C 'made':31B 'may':45B 'miss':7A,36B,58C 'multi':4A,19B,26B,66C 'multi-curr':3A,25B 'n/a':80C 'packag':16B 'perform':49B,57B 'plugin':6A,28B 'secur':74C 'user':44B 'version':40B 'villathem':33B,62C 'vulner':60C 'woo':18B,65C 'woo-multi-curr':17B,64C 'woocommerc':2A,21B,30B 'wordpress':22B","nicknames":[],"mitigations":[],"who_affected":"Sites running the CURCY (woo-multi-currency) WooCommerce plugin at version 2.2.20 or earlier. The sources do not say which actions are reachable or whether a default configuration is exposed, so the exact exposure is unknown.","tier":"C","verified":{},"analyst_revisit_at":null,"fix_status":"none","audience":"businesses","plain_action":null,"pkeys":[],"ptokens":[],"labels":["medium","package","woocommerce","woomulticurrency","wordpress"],"campaign_type":null,"search_a":"'-121775':12A,15A '-2026':11A,14A 'author':8A 'check':9A 'curci':1A 'currenc':5A 'cve':10A,13A 'miss':7A 'multi':4A 'multi-curr':3A 'plugin':6A 'woocommerc':2A","search_b":"'2.2.20':42B 'abl':47B 'action':50B 'allow':55B 'author':37B 'check':38B 'curci':24B 'currenc':20B,27B 'made':31B 'may':45B 'miss':36B 'multi':19B,26B 'multi-curr':25B 'packag':16B 'perform':49B,57B 'plugin':28B 'user':44B 'version':40B 'villathem':33B 'woo':18B 'woo-multi-curr':17B 'woocommerc':21B,30B 'wordpress':22B","search_c":"'2.2.20':82C 'access':72C 'affect':77C 'allow':68C 'author':59C 'configur':71C 'control':73C 'curci':63C,78C 'currenc':67C 'exploit':69C 'incorrect':70C 'issu':76C 'levels.this':75C 'miss':58C 'multi':66C 'n/a':80C 'secur':74C 'villathem':62C 'vulner':60C 'woo':65C 'woo-multi-curr':64C","first_public_at":"2026-11-07T13:16:35+00:00","kev":null,"cvss_vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N","cvss_by":"audit@patchstack.com","poc_count":0,"sources":[{"source":"nvd","external_id":"CVE-2026-121775","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-121775","severity":null,"published_at":"2026-11-07T13:16:35+00:00","modified_at":"2026-11-07T13:16:35+00:00","first_seen_at":"2026-11-07T13:47:25+00:00","fetched_at":"2026-11-07T13:47:25+00:00","note":null}],"documents":[],"exploit_sources":[],"notice":"Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai"}