---
id: "CVE-2026-121762"
page: "https://infrastack.ai/live/CVE-2026-121762"
kind: "vulnerability"
aliases: ["CVE-2026-121762"]
title: "PowerPress WordPress plugin: cross-site request forgery through version 11.18.0"
severity: "high"
cvss: 8.8
epss: null
exploited: false
status: "open"
category: "package"
products: [{"name": "powerpress", "fixed": [], "affected": "<= 11.18.0", "ecosystem": "wordpress"}]
ecosystems: []
tags: ["auth-required", "package", "podcasting", "powerpress", "wordpress"]
not_affected_if: ["plugin-not-installed"]
published_at: "2026-11-07T10:17:11+00:00"
first_seen_at: "2026-11-07T10:46:41+00:00"
updated_at: "2026-11-07T10:49:36+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-121762", "first_seen_at": "2026-11-07T10:46:41+00:00"}, {"source": "analyst", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-121762", "first_seen_at": "2026-11-07T10:49:36+00:00", "cites": ["https://nvd.nist.gov/vuln/detail/CVE-2026-121762", "https://patchstack.com/database/wordpress/plugin/powerpress/vulnerabilities"]}]
exploit_sources: []
---

# PowerPress WordPress plugin: cross-site request forgery through version 11.18.0

Link for people: https://infrastack.ai/live/CVE-2026-121762 (this .md is for agents)

PowerPress is a WordPress podcasting plugin from Blubrry. A flaw in it lets an attacker trick a logged-in site administrator's browser into submitting actions the administrator did not intend.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- wordpress:powerpress affected <= 11.18.0 fixed no fixed version listed

## How to check

- Check the installed PowerPress version in the WordPress admin Plugins page or with `wp plugin get powerpress --field=version`
- Confirm whether the installed version is `11.18.0` or earlier

## Timeline

- 2026-11-07T10:46:41+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-121762
- 2026-11-07T10:49:36+00:00 analyst https://nvd.nist.gov/vuln/detail/CVE-2026-121762 — NVD/Patchstack (CVSS 8.8, AV:N/PR:N/UI:R) list PowerPress <= 11.18.0 as CSRF. No vendor advisory, fixed version, or list of affected actions found; wordpress.org plugin page (modified 2026-11-03) gave no changelog in the text I read. Fix left unknown; check the plugin changelog for a release newer than 11.18.0. Nothing verified, since only NVD and a third-party database were read. No exploitation or PoC found. Earlier PowerPress CSRFs were fixed in 11.14 and 11.17.11.

## Documents

- [advisory] NVD CVE-2026-121762 https://nvd.nist.gov/vuln/detail/CVE-2026-121762
- [mentions] Patchstack PowerPress vulnerability history https://patchstack.com/database/wordpress/plugin/powerpress/vulnerabilities

## From the sources

Cross-Site Request Forgery (CSRF) vulnerability in Blubrry Podcasting PowerPress Podcasting powerpress allows Cross Site Request Forgery.This issue affects PowerPress Podcasting: from n/a through 11.18.0.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
