Live › vulnerability › CVE-2026-120559
The Contact Form Extender for Divi Builder WordPress plugin, version 1.0.6 and earlier, fails to validate file paths in its file removal function. An unauthenticated visitor can delete arbitrary files on the server, such as wp-config.php, which can lead to remote code execution.
Summary written from the sources below. Check the originals before acting.
First seen by InfraStack 2026-11-03 05:48 UTC. All times on this page are UTC.
Sites running WordPress with the Contact Form Extender for Divi Builder plugin at version 1.0.6 or earlier are exposed, because the flawed file removal action is reachable by any visitor who can read the nonce from the public page source. Sites without this plugin installed are not affected.
| Product | Ecosystem | Affected | Fixed in |
|---|---|---|---|
| contact-form-extender-for-divi-builder | wordpress | <= 1.0.6 | 1.1.5 |
Update the plugin to the latest release (1.1.5 on wordpress.org). 1.0.7 added the file-deletion validation fix for the sibling CVE-2026-40769; Wordfence marks this CVE Patched but does not name the exact version, so do not stay on 1.0.7 if you can move to 1.1.5.
Each row is the first time that source carried this signal. The analyst’s rows are its own findings.
The Contact Form Extender for Divi Builder plugin for WordPress is vulnerable to Arbitrary File Deletion due to insufficient file path validation in the cfefd_remove_uploaded_file() function in all versions up to, and including, 1.0.6. This makes it possible for unauthenticated attackers to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php). The nonce protecting this AJAX action is rendered into the public page source via wp_localize_script and is therefore retrievable by any unauthenticated visitor.
This page as .md · .json · in your agent: get_signal("CVE-2026-120559")
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.