---
id: "CVE-2026-120218"
kind: "vulnerability"
aliases: ["CVE-2026-120218"]
title: "Typemill: SVG upload sanitizer flaw enables cross-site scripting"
severity: "medium"
cvss: 4.0
epss: 0.00254
exploited: false
status: "open"
category: "other"
products: []
ecosystems: []
tags: ["other", "php", "self-hosted", "typemill"]
not_affected_if: ["version-2.27.0-or-later"]
published_at: "2026-11-01T07:17:26+00:00"
first_seen_at: "2026-11-01T07:18:34+00:00"
updated_at: "2026-11-01T16:46:41+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-120218", "first_seen_at": "2026-11-01T07:18:34+00:00"}, {"source": "epss", "url": "https://api.first.org/data/v1/epss?cve=CVE-2026-120218", "first_seen_at": "2026-11-01T16:46:41+00:00"}]
---

# Typemill: SVG upload sanitizer flaw enables cross-site scripting

Typemill up to version 2.26.0 has a flaw in its image save function, where the SVG sanitizer can be bypassed. A remote attacker can use it to run cross-site scripting in a visitor's browser.

_Summary, check and fix written by a model from the sources; labelled as such._

## How to check

- Check the installed Typemill version and see whether it is `2.26.0` or older.
- Review whether image uploads in Typemill accept SVG files.

## Fix

- Typemill: upgrade to `2.27.0`.

## Timeline

- 2026-11-01T07:18:34+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-120218
- 2026-11-01T16:46:41+00:00 epss https://api.first.org/data/v1/epss?cve=CVE-2026-120218

## Documents

- [fix] Patch: github.com https://github.com/typemill/typemill/commit/9ca43c4a7b6764c5a6ac11a2ccc099b036ee3cef
- [fix] Release notes: github.com https://github.com/typemill/typemill/releases/tag/v2.27.0

## From the sources

A flaw has been found in Typemill up to 2.26.0. The impacted element is the function ControllerApiImage::saveImage of the file system/typemill/Models/SvgSanitizer.php. Executing a manipulation can lead to cross site scripting. The attack may be performed from remote. The exploit has been published and may be used. Upgrading to version 2.27.0 is sufficient to resolve this issue. This patch is called 9ca43c4a7b6764c5a6ac11a2ccc099b036ee3cef. It is recommended to upgrade the affected component.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
