---
id: "CVE-2026-120185"
kind: "vulnerability"
aliases: ["CVE-2026-120185"]
title: "YznCMS: auth group handler flaw enables improper privilege management"
severity: "medium"
cvss: 5.8
epss: null
exploited: false
status: "open"
category: "other"
products: []
ecosystems: []
tags: ["other", "php", "self-hosted", "yzncms"]
not_affected_if: ["fixed-2.2.1", "not-yzncms"]
published_at: "2026-10-31T23:17:11+00:00"
first_seen_at: "2026-10-31T23:46:48+00:00"
updated_at: "2026-10-31T23:48:44+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-120185", "first_seen_at": "2026-10-31T23:46:48+00:00"}]
---

# YznCMS: auth group handler flaw enables improper privilege management

YznCMS, a PHP content management system, has a flaw in its admin auth group handler (app/admin/controller/auth/Group.php) that mishandles privileges. A remote attacker can use it to gain access beyond what their role allows, according to the NVD entry.

_Summary, check and fix written by a model from the sources; labelled as such._

## How to check

- Check the YznCMS version in the project, looking for any release up to `2.2.0`
- Review `app/admin/controller/auth/Group.php` in the deployed code to confirm it is present

## Fix

- YznCMS: upgrade to `2.2.1`

## Timeline

- 2026-10-31T23:46:48+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-120185

## From the sources

A security flaw has been discovered in ken678 YznCMS up to 2.2.0. The affected element is the function Backend of the file app/admin/controller/auth/Group.php of the component Auth Group Handler. Performing a manipulation results in improper privilege management. The attack can be initiated remotely. Upgrading to version 2.2.1 is sufficient to fix this issue. The patch is named ed16cd7f7f73e0316ffa8a148d. You should upgrade the affected component.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
