---
id: "CVE-2026-120082"
page: "https://infrastack.ai/live/CVE-2026-120082"
kind: "vulnerability"
aliases: ["CVE-2026-120082"]
title: "WordPress GeoDirectory plugin: unauthenticated stored XSS via post content"
severity: "high"
cvss: 7.2
epss: null
exploited: false
status: "open"
category: "package"
products: [{"name": "geodirectory", "fixed": ["2.8.201"], "affected": "<= 2.8.200", "ecosystem": "wordpress"}]
ecosystems: []
tags: ["geodirectory", "package", "self-hosted", "wordpress"]
not_affected_if: ["patched-2.8.201", "plugin-not-installed"]
published_at: "2026-11-07T03:17:02+00:00"
first_seen_at: "2026-11-07T03:45:33+00:00"
updated_at: "2026-11-07T03:48:29+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-120082", "first_seen_at": "2026-11-07T03:45:33+00:00"}, {"source": "analyst", "url": "https://www.wordfence.com/threat-intel/vulnerabilities/wordpress-plugins/geodirectory/geodirectory-28200-unauthenticated-stored-cross-site-scripting-via-nested-gd-dynamic-content-shortcode-in-post-content", "first_seen_at": "2026-11-07T03:48:29+00:00", "cites": ["https://www.wordfence.com/threat-intel/vulnerabilities/wordpress-plugins/geodirectory/geodirectory-28200-unauthenticated-stored-cross-site-scripting-via-nested-gd-dynamic-content-shortcode-in-post-content", "https://wpgeodirectory.com/change-logs/"]}]
exploit_sources: []
---

# WordPress GeoDirectory plugin: unauthenticated stored XSS via post content

Link for people: https://infrastack.ai/live/CVE-2026-120082 (this .md is for agents)

The GeoDirectory WordPress directory plugin does not sanitize the post_content parameter well enough, so unauthenticated attackers can store scripts in pages. Those scripts run in the browser of any user who opens the injected page.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- wordpress:geodirectory affected <= 2.8.200 fixed 2.8.201

## How to check

- In WordPress admin > Plugins, check the GeoDirectory version; 2.8.200 or earlier is affected, 2.8.201 or later is fixed.
- Or run: wp plugin get geodirectory --field=version
- Review recently submitted listings/posts for nested shortcodes such as [gd_dynamic_conten[gd_tags]t ...] or entity-encoded attributes in post_content.

## Fix

Update GeoDirectory to 2.8.201 or later (latest listed by the vendor: 2.8.202, 2026-11-04).

## Timeline

- 2026-11-07T03:45:33+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-120082
- 2026-11-07T03:48:29+00:00 analyst https://www.wordfence.com/threat-intel/vulnerabilities/wordpress-plugins/geodirectory/geodirectory-28200-unauthenticated-stored-cross-site-scripting-via-nested-gd-dynamic-content-shortcode-in-post-content — Wordfence advisory: affected <= 2.8.200, patched 2.8.201. Vendor changelog 2.8.201 (2026-11-02): 'Strip nested shortcodes & sanitize Dynamic Content widget html to prevent XSS' (vendor does not name the CVE; match via Wordfence's description). No exploitation or public PoC found; not checked social posts.

## Documents

- [advisory] Wordfence: GeoDirectory <= 2.8.200 Unauthenticated Stored XSS https://www.wordfence.com/threat-intel/vulnerabilities/wordpress-plugins/geodirectory/geodirectory-28200-unauthenticated-stored-cross-site-scripting-via-nested-gd-dynamic-content-shortcode-in-post-content
- [fix] GeoDirectory Changelog (v2.8.201) https://wpgeodirectory.com/change-logs/

## From the sources

The GeoDirectory – WP Business Directory Plugin and Classified Listings Directory plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'post_content' parameter in all versions up to, and including, 2.8.200 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The nested shortcode payload ([gd_dynamic_conten[gd_tags]t ...]) defeats the plugin's geodir_strip_shortcodes() guard because WordPress's strip_shortcodes() performs only a single pass over registered tags, and HTML-entity-encoded attributes in the resulting shortcode survive wp_kses_post() because kses inspects HTML tags rather than shortcode attribute values.

---

_Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai_
