---
id: "CVE-2026-119978"
kind: "vulnerability"
aliases: ["CVE-2026-119978"]
title: "Flowise: authenticated users can run OS commands through custom functions"
severity: "critical"
cvss: 9.0
epss: null
exploited: false
status: "open"
category: "ai-tooling"
products: [{"name": "flowise", "fixed": [], "affected": "<= 3.1.4", "ecosystem": "npm"}]
ecosystems: []
tags: ["ai-tooling", "flowise", "langchain", "node", "self-hosted"]
not_affected_if: ["auth-required", "default-config", "no-untrusted-accounts"]
published_at: "2026-10-30T18:17:27+00:00"
first_seen_at: "2026-10-30T18:55:29+00:00"
updated_at: "2026-10-30T18:57:43+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-119978", "first_seen_at": "2026-10-30T18:55:29+00:00"}, {"source": "analyst", "url": null, "first_seen_at": "2026-10-30T18:57:43+00:00"}]
---

# Flowise: authenticated users can run OS commands through custom functions

Self-hosted Flowise up to 3.1.4 is exposed when ALLOW_BUILTIN_DEP=true and someone with a login or API key can reach /api/v1/node-custom-function. They can write a file into the mammoth package via the langchain LocalFileStore, require it, escape vm2 and run OS commands as the Flowise user (root in the official Docker image). Instances without ALLOW_BUILTIN_DEP=true or without untrusted users can skip it. No fixed version is published yet.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- npm:flowise affected <= 3.1.4 fixed ?

## How to check

- Check the installed Flowise version against the affected range through 3.1.4.
- Check whether `ALLOW_BUILTIN_DEP` is set to `true` in the Flowise environment.
- Check whether the `/api/v1/node-custom-function` endpoint is reachable by untrusted users.

## Timeline

- 2026-10-30T18:55:29+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-119978
- 2026-10-30T18:57:43+00:00 analyst — No Flowise advisory or fix found for this CVE; NVD/OpenCVE say affected <=3.1.4 and 3.1.4 is the latest release (Vulert, 28 Oct), so no known fixed version. Sibling GHSA-9gvv-qjj3-2p6g (puppeteer allowlist, same endpoint, fixed 3.1.3) is a different path (this one: langchain LocalFileStore + mammoth). Nothing verified. Recheck Flowise advisories/releases after 3.1.4.

## Documents

- [describes] OpenCVE: CVE-2026-119978 (mirrors NVD description) https://app.opencve.io/cve/CVE-2026-119978
- [mentions] Flowise GHSA-9gvv-qjj3-2p6g: sibling sandbox escape via puppeteer allowlist, fixed 3.1.3 https://github.com/FlowiseAI/Flowise/security/advisories/GHSA-9gvv-qjj3-2p6g

## From the sources

Flowise through 3.1.4 contains a sandbox escape vulnerability that allows authenticated users to execute OS commands by abusing allowlisted langchain and mammoth modules when ALLOW_BUILTIN_DEP=true. Attackers can submit JavaScript to /api/v1/node-custom-function that writes a file into the mammoth package via LocalFileStore and requires it, escaping vm2 as the Flowise process user.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
