---
id: "CVE-2026-119777"
kind: "vulnerability"
aliases: ["CVE-2026-119777"]
title: "GStreamer: malformed H.266 file can overflow stack and run code"
severity: "high"
cvss: 7.8
epss: null
exploited: false
status: "open"
category: "package"
products: [{"name": "gst-plugins-bad", "fixed": ["1.28.2"], "affected": ">= 1.25.1, < 1.28.2", "ecosystem": "vendor"}]
ecosystems: []
tags: ["gst-plugins-bad", "gstreamer", "linux", "media-pipeline", "package"]
not_affected_if: ["gst-plugins-bad-1.28.2-or-later", "gstreamer-below-1.25.1", "no-vvc-processing"]
published_at: "2026-10-30T18:17:27+00:00"
first_seen_at: "2026-10-30T18:55:29+00:00"
updated_at: "2026-10-30T18:57:35+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-119777", "first_seen_at": "2026-10-30T18:55:29+00:00"}, {"source": "analyst", "url": null, "first_seen_at": "2026-10-30T18:57:35+00:00"}]
---

# GStreamer: malformed H.266 file can overflow stack and run code

GStreamer's gst-plugins-bad H.266/VVC parser mishandles profile, tier and level fields in a malformed file or stream, causing an integer overflow that leads to a stack-based buffer overflow. An attacker may crash the application or run code in its context.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- vendor:gst-plugins-bad affected >= 1.25.1, < 1.28.2 fixed 1.28.2

## How to check

Run 'gst-inspect-1.0 --version' or your package manager (e.g. dpkg -l 'gstreamer1.0-plugins-bad', rpm -q gstreamer1-plugins-bad-free). Versions >= 1.25.1 and < 1.28.2 are affected. Check the vvc parser exists: gst-inspect-1.0 h266parse.

## Fix

Upgrade gst-plugins-bad to 1.28.2 or later (distro packages: the build that backports the 1.28.2 fix); older versions must apply the patch and recompile.

## Timeline

- 2026-10-30T18:55:29+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-119777
- 2026-10-30T18:57:35+00:00 analyst — Upstream advisory GStreamer-SA-2026-0017 (2026-04-07) matches this description exactly (H.266/VVC profile/tier/level integer overflow -> stack overflow): affected gst-plugins-bad >= 1.25.1, < 1.28.2, fixed in 1.28.2. Caveat: that page says 'No CVE number assigned', so the match to CVE-2026-119777 is by description; Red Hat is the CNA. Distro backport versions not checked. No known exploitation or PoC found.

## Documents

- [advisory] GStreamer Security Advisory 2026-0017 https://gstreamer.freedesktop.org/security/sa-2026-0017.html

## From the sources

A flaw was found in GStreamer's gst-plugins-bad H.266/VVC parser. When processing a malformed H.266 media file or stream, an integer overflow while parsing profile, tier, and level fields can lead to a stack-based buffer overflow. An attacker could cause an application to crash and may be able to execute code in the context of the affected application.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
