PIE-REGISTER · CVE-2026-119488 · Package
FIX → 3.8.4.16
Pie Register, a WordPress user registration plugin by Shamim Rajani, has a stored cross-site scripting flaw in versions up to 3.8.4.15. An attacker can save script code that runs in the browser of other users who view the affected page.
first public Nov 6, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
WordPress sites running the Pie Register plugin at version 3.8.4.15 or earlier. The NVD record gives a CVSS vector with no privileges required and user interaction needed, but no source read says which field stores the payload. Sites without the plugin, or already on 3.8.4.16 or later, can skip it.
Not affected if patched-3.8.4.16, plugin-not-installed
Who cares pie-register, stored-xss, wordpress, xss
Upgrade to 3.8.4.16
Update Pie Register to 3.8.4.16 or later (reported via Patchstack relay, not confirmed on vendor changelog). 3.8.4.17 is current per WPSec and also fixes a separate avatar XSS, so move to the latest version.
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Shamim Rajani Pie Register pie-register allows Stored XSS.This issue affects Pie Register: from n/a through 3.8.4.15.
This page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.