{"id":"CVE-2026-119176","kind":"vulnerability","aliases":["CVE-2026-119176"],"related":[],"title":"WordPress CP Multi View Events Calendar plugin: stored cross-site scripting via Subject field","description":"The CP Multi View Events Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'Subject' parameter in all versions up to, and including, 1.4.43 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The required nonce is localized to any published page carrying the calendar shortcode, making the adddetails endpoint reachable by any authenticated user with Subscriber-level access or above.","summary":"The CP Multi View Events Calendar WordPress plugin up to and including 1.4.43 does not sanitize the 'Subject' parameter of calendar events. A logged-in subscriber can store a script that runs in the browser of any user who opens the affected page.","severity":"medium","cvss":6.4,"epss":null,"exploited":false,"exploited_at":null,"products":[],"ecosystems":[],"tags":["cp-multi-view-events-calendar","package","wordpress","wp-plugin"],"not_affected_if":["no-subscriber-accounts","patched-version","plugin-not-installed"],"how_to_check":"- Check the installed plugin version in the WordPress admin plugin list or the plugin's main file header; affected if it is `1.4.43` or older\n- Look for the calendar shortcode on published pages, since the nonce is exposed on any such page","fix":null,"status":"open","published_at":"2026-10-30T18:17:25+00:00","first_seen_at":"2026-10-30T18:55:29+00:00","triaged_at":"2026-10-30T18:57:04+00:00","updated_at":"2026-10-30T18:57:04+00:00","category":"package","confidence":0.7,"triage":{"at":"2026-10-30T18:57:04Z","model":"claude-haiku-5-5","output":{"fix":"- Move the CP Multi View Events Calendar plugin to a version later than `1.4.43` (the sources do not name the fixed version)","reach":"internet","title":"WordPress CP Multi View Events Calendar plugin: stored cross-site scripting via Subject field","impact":"medium","summary":"The CP Multi View Events Calendar WordPress plugin up to and including 1.4.43 does not sanitize the 'Subject' parameter of calendar events. A logged-in subscriber can store a script that runs in the browser of any user who opens the affected page.","audience":"businesses","category":"package","nicknames":[],"who_cares":["wordpress","wp-plugin","cp-multi-view-events-calendar"],"confidence":0.7,"fix_status":"unknown","needs_auth":"yes","worst_case":"Attacker script runs in visitors' browsers and steals admin sessions","analyst_note":"Confirm the first patched version of the CP Multi View Events Calendar plugin from the WordPress.org changelog or the NVD entry.","how_to_check":"- Check the installed plugin version in the WordPress admin plugin list or the plugin's main file header; affected if it is `1.4.43` or older\n- Look for the calendar shortcode on published pages, since the nonce is exposed on any such page","plain_action":"","needs_analyst":true,"not_affected_if":["plugin-not-installed","no-subscriber-accounts","patched-version"],"who_is_affected":"Sites running CP Multi View Events Calendar version 1.4.43 or older where subscriber-level accounts exist, including sites that allow open registration. The calendar shortcode on a published page exposes the needed nonce to any subscriber. Sites without this plugin, or with it updated past 1.4.43, are not affected.","user_interaction":"yes","needs_special_setup":"no","severity_if_unknown":"medium"},"cost_usd":0.000746,"input_tokens":4232,"output_tokens":646,"severity_before":"medium"},"analyst_status":null,"analyst_note":null,"search":"'-119176':18A,21A '-2026':17A,20A '1.4.43':45B,105C 'access':125C,141C,171C 'adddetail':160C 'affect':75B 'arbitrari':130C 'attack':120C 'authent':119C,165C 'browser':68B 'calendar':6A,27B,38B,53B,82C,156C 'carri':154C 'cp':2A,23B,34B,78C 'cp-multi-view-events-calendar':22B 'cross':10A,91C 'cross-sit':9A,90C 'cve':16A,19A 'due':106C 'endpoint':161C 'escap':113C 'event':5A,26B,37B,54B,81C 'execut':137C 'field':15A 'includ':44B,104C 'inject':129C,143C 'input':109C 'insuffici':108C 'level':124C,170C 'local':149C 'log':57B 'logged-in':56B 'make':115C,158C 'multi':3A,24B,35B,79C 'nonc':147C 'open':73B 'output':112C 'packag':28B 'page':76B,134C,144C,153C 'paramet':51B,97C 'plugin':7A,32B,40B,83C 'possibl':117C 'publish':152C 'reachabl':162C 'requir':146C 'run':65B 'sanit':48B,110C 'script':12A,63B,93C,132C 'shortcod':157C 'site':11A,92C 'store':8A,61B,89C 'subject':14A,50B,96C 'subscrib':59B,123C,169C 'subscriber-level':122C,168C 'user':71B,140C,166C 'version':100C 'via':13A,94C 'view':4A,25B,36B,80C 'vulner':87C 'web':131C 'whenev':138C 'wordpress':1A,29B,39B,85C 'wp':31B 'wp-plugin':30B","nicknames":[],"mitigations":[],"who_affected":"Sites running CP Multi View Events Calendar version 1.4.43 or older where subscriber-level accounts exist, including sites that allow open registration. The calendar shortcode on a published page exposes the needed nonce to any subscriber. Sites without this plugin, or with it updated past 1.4.43, are not affected.","tier":"C","verified":{},"analyst_revisit_at":null,"fix_status":"none","audience":"businesses","plain_action":null,"first_public_at":"2026-10-30T18:17:25+00:00","kev":null,"cvss_vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","cvss_by":"security@wordfence.com","poc_count":0,"sources":[{"source":"nvd","external_id":"CVE-2026-119176","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-119176","severity":null,"published_at":"2026-10-30T18:17:25+00:00","modified_at":"2026-10-30T18:33:26+00:00","first_seen_at":"2026-10-30T18:55:29+00:00","fetched_at":"2026-10-30T18:55:29+00:00","note":null}],"documents":[],"notice":"Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai"}