WPFORO · CVE-2026-119164 · Package
FIX → 3.2.3
The wpForo Forum plugin for WordPress lets any logged-in Subscriber inject extra forum group IDs into their profile through the secondary_groupids field. Injecting the Admin group ID gives the attacker wpForo Administrator rights, including editing content owned by other users and rewriting forum-wide permissions.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Sites running the wpForo Forum plugin on WordPress with versions up to and including 3.2.2. The attacker needs a Subscriber-level account and at least 3 approved forum posts, so sites with open registration are the most exposed. Sites without wpForo, or where user registration is closed and trusted, are not affected.
Not affected if no-wpforo-plugin, plugin-above-3.2.2, registration-closed
Who cares self-hosted, wordpress, wpforo
Upgrade to 3.2.3
Update the wpForo Forum plugin to 3.2.3 or later (Wordfence, Patchstack).
The wpForo Forum plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 3.2.2 via the data[secondary_groupids] parameter of the wpforo_action_profile_update POST handler. This is due to a type-confusion flaw in the secondary_groupids authorization guard within the Members::update() function in classes/Members.php, where casting a scalar CSV string (e.g. "0,1") with (array) before array_map('intval', …) and array_filter() produces an empty array — causing the guard's outer conditional, and the else-branch that would otherwise strip the field from the update, to be bypassed entirely — while encode()/decode() downstream correctly explodes the original CSV and persists the attacker-supplied group IDs to wp_wpforo_profiles.secondary_groupids. This makes it possible for authenticated attackers, with Subscriber-level access and above, to escalate their forum privileges to wpForo Administrator by injecting the privileged Admin group ID, granting access to the Forum Accesses editor and the ability to rewrite forum-wide capability policies for all members and edit arbitrary content owned by other users. Exploitation requires the attacker to have at least 3 approved wpForo posts to satisfy the plugin's default antispam gate, along with a valid wpforo nonce obtained from their own account profile form.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
min_number_posts_to_edit_accountThis page as .md · .json · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.