DOWNLOAD-MANAGER · CVE-2026-119156 · Package
FIX → 7.6.4 · 3.3.75
A flaw in the Download Manager WordPress plugin's registration form lets an unauthenticated visitor store a script in the first administrator's name. WPSec describes it: a refused signup (e.g. username over 60 characters) updates user 1. The script then runs in visitors' browsers when a package by that admin is shown with the Spotlight template.
first public Nov 7, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Sites running the Download Manager WordPress plugin up to and including 7.5.9 that allow public registration and publish the [wpdm_reg_form] shortcode on a public page. The sources say exposure also needs at least one package authored by user ID 1 rendered with the Spotlight link template. Sites with registration closed, no public registration form, or a plugin version newer than 7.5.9 can skip it.
Not affected if default-config, no-spotlight-template, no-wpdm-reg-form, registration-disabled
Who cares download-manager, self-hosted, wordpress
wp plugin get download-manager --field=version: exposed if 7.5.9 or earlier, or 3.3.45 to 3.3.74 (free build per WPSec); fixed in 7.6.4 / 3.3.75.Upgrade to 7.6.4 · 3.3.75
The Download Manager plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'wpdm_reg[first_name], wpdm_reg[last_name], wpdm_reg[user_login]' parameter in all versions up to, and including, 7.5.9 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires the site to have "Anyone can register" enabled, the plugin's [wpdm_reg_form] shortcode published on a public page, and at least one package authored by user ID 1 rendered with the Spotlight link template.
This page as .md ·
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
7.6.4 or later (Wordfence)3.3.75 or later (WPSec)NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.