---
id: "CVE-2026-118549"
kind: "vulnerability"
aliases: ["CVE-2026-118549"]
title: "Drupal AI module: cross-site scripting flaw in versions up to 1.5.2"
severity: "unknown"
cvss: null
epss: null
exploited: false
status: "open"
category: "ai-tooling"
products: []
ecosystems: []
tags: ["ai-tooling", "cms", "drupal", "php"]
not_affected_if: ["module-not-installed"]
published_at: "2026-10-30T04:18:20+00:00"
first_seen_at: "2026-10-30T04:28:38+00:00"
updated_at: "2026-10-30T04:29:29+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-118549", "first_seen_at": "2026-10-30T04:28:38+00:00"}]
---

# Drupal AI module: cross-site scripting flaw in versions up to 1.5.2

The Drupal AI (Artificial Intelligence) module fails to neutralize input when generating web pages, which enables cross-site scripting. An attacker can get script to run in another user's browser session on the affected site.

_Summary, check and fix written by a model from the sources; labelled as such._

## How to check

- Check the installed AI module version on the Drupal site, for example with `drush pm:list --filter=ai`
- Confirm whether the installed version falls in `0.0.0` to `1.4.11` or `1.5.0` to `1.5.2`

## Fix

- Move the AI module to a version later than `1.5.2`, or to the fixed release in the 1.4 line later than `1.4.11`; the sources do not name the exact fixed version

## Timeline

- 2026-10-30T04:28:38+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-118549

## From the sources

Improper Neutralization of Input During Web Page Generation ("Cross-site Scripting") vulnerability in Drupal AI (Artificial Intelligence) allows Cross-Site Scripting (XSS). This issue affects AI (Artificial Intelligence) versions: from 0.0.0 to 1.4.11, from 1.5.0 to 1.5.2.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
