---
id: "CVE-2026-118548"
kind: "vulnerability"
aliases: ["CVE-2026-118548"]
title: "Drupal AI module: incorrect authorization allows resource injection"
severity: "medium"
cvss: null
epss: null
exploited: false
status: "open"
category: "ai-tooling"
products: [{"name": "drupal/ai", "fixed": ["1.4.11", "1.5.2"], "affected": "< 1.4.11, >= 1.5.0 < 1.5.2", "ecosystem": "packagist"}]
ecosystems: []
tags: ["ai-module", "ai-tooling", "composer", "drupal", "php"]
not_affected_if: ["module-not-installed", "no-untrusted-input"]
published_at: "2026-10-30T04:18:19+00:00"
first_seen_at: "2026-10-30T04:28:38+00:00"
updated_at: "2026-10-30T04:30:44+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-118548", "first_seen_at": "2026-10-30T04:28:38+00:00"}, {"source": "analyst", "url": null, "first_seen_at": "2026-10-30T04:30:44+00:00"}]
---

# Drupal AI module: incorrect authorization allows resource injection

The Drupal AI module does not sufficiently validate links under certain conditions. When it renders HTML built from untrusted content, sensitive information can be exfiltrated to external sites. Drupal rates it moderately critical (11/25), with exploit maturity theoretical.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- packagist:drupal/ai affected < 1.4.11, >= 1.5.0 < 1.5.2 fixed 1.4.11, 1.5.2

## How to check

Run 'composer show drupal/ai' or 'drush pm:list --filter=ai' and compare the version. You are affected if it is below 1.4.11, or from 1.5.0 up to but not including 1.5.2 (1.3.x and older are affected and unsupported).

## Fix

Upgrade the drupal/ai module: 1.5.x to 1.5.2, 1.4.x to 1.4.11. The 1.3.x branch is unsupported, so move to 1.5.2 or 1.4.11.

## Timeline

- 2026-10-30T04:28:38+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-118548
- 2026-10-30T04:30:44+00:00 analyst — Read Drupal SA-CONTRIB-2026-268 (primary). Info disclosure via unvalidated links in AI-rendered HTML; fixed 1.4.11 / 1.5.2. Drupal rates moderately critical, theoretical exploit; no exploitation or PoC found.

## Documents

- [advisory] SA-CONTRIB-2026-268: AI (Artificial Intelligence) - Information disclosure https://www.drupal.org/sa-contrib-2026-268

## From the sources

Incorrect Authorization vulnerability in Drupal AI (Artificial Intelligence) allows Resource Injection. This issue affects AI (Artificial Intelligence) versions: from 0.0.0 to 1.4.11, from 1.5.0 to 1.5.2.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
