{"id":"CVE-2026-118545","kind":"vulnerability","aliases":["CVE-2026-118545"],"related":[],"title":"Drupal AI module: cross-site scripting lets attackers run scripts in pages","description":"Improper Neutralization of Input During Web Page Generation (\"Cross-site Scripting\") vulnerability in Drupal AI (Artificial Intelligence) allows Cross-Site Scripting (XSS). This issue affects AI (Artificial Intelligence) versions: from 0.0.0 to 1.4.11, from 1.5.0 to 1.5.2.","summary":"The Drupal AI module does not sufficiently restrict HTML rendering, so cross-site scripting is possible under certain conditions. The attacker must have access to a text format that can render HTML. Fixed in AI 1.4.11 and 1.5.2.","severity":"medium","cvss":null,"epss":null,"exploited":false,"exploited_at":null,"products":[{"name":"drupal/ai","fixed":["1.4.11","1.5.2"],"affected":"< 1.4.11, >= 1.5.0 < 1.5.2","ecosystem":"packagist"}],"ecosystems":[],"tags":["ai-tooling","cms","drupal","drupal-ai","php"],"not_affected_if":["no-html-text-formats","unaffected-version"],"how_to_check":"Run 'composer show drupal/ai' or 'drush pm:list --filter=ai'. You are exposed if the version is below 1.4.11 on the 1.4 branch, below 1.5.2 on 1.5, or on any 1.3.x or older release. The attacker needs access to a text format that can render HTML, so also review which roles can use such formats.","fix":"Upgrade the Drupal AI module: 1.5.x to 1.5.2, 1.4.x to 1.4.11. Sites on 1.3.x (unsupported) must move to 1.4.11 or 1.5.2. For example: composer require drupal/ai:^1.5.2 then drush updb && drush cr.","status":"open","published_at":"2026-10-30T04:18:19+00:00","first_seen_at":"2026-10-30T04:28:38+00:00","triaged_at":"2026-10-30T04:29:32+00:00","updated_at":"2026-10-30T04:30:54+00:00","category":"ai-tooling","confidence":0.9,"triage":{"at":"2026-10-30T04:29:32Z","model":"claude-haiku-5-5","output":{"fix":"- Move the Drupal AI module beyond the affected ranges; the NVD entry does not state a fixed version, so check the Drupal.org security advisory.","reach":"internet","title":"Drupal AI module: cross-site scripting lets attackers run scripts in pages","impact":"medium","summary":"The Drupal AI (Artificial Intelligence) module fails to neutralize input when generating web pages, enabling cross-site scripting. An attacker can inject script that runs in another user's browser on the affected site.","audience":"businesses","category":"ai-tooling","nicknames":[],"who_cares":["drupal","php","cms"],"confidence":0.5,"fix_status":"unknown","needs_auth":"unknown","worst_case":"script runs in other users' browsers, session data exposed","analyst_note":"Confirm the fixed version and the trigger conditions on the Drupal.org security advisory for the Drupal AI module.","how_to_check":"- Check the installed version of the Drupal AI module (for example with `drush pm:list --filter=ai`) and compare it to the affected range.\n- Affected versions per NVD: from `0.0.0` to `1.4.11`, and `1.5.0` to `1.5.2`.","plain_action":"","needs_analyst":true,"not_affected_if":["unaffected-version"],"who_is_affected":"Sites running the Drupal AI (Artificial Intelligence) module in an affected version range. The sources do not say which features or configurations are needed to reach the flaw, so unknown whether all installs are exposed.","user_interaction":"unknown","needs_special_setup":"unknown","severity_if_unknown":"low"},"cost_usd":0.000698,"input_tokens":4148,"output_tokens":566,"severity_before":"unknown"},"analyst_status":"done","analyst_note":"Confirm the fixed version and the trigger conditions on the Drupal.org security advisory for the Drupal AI module.","search":"'-118545':16A,19A '-2026':15A,18A '0.0.0':101C '1.4.11':66B,103C '1.5.0':105C '1.5.2':68B,107C 'access':54B 'affect':95C 'ai':2A,22B,28B,32B,65B,84C,96C 'ai-tool':21B 'allow':87C 'artifici':85C,97C 'attack':9A,51B 'certain':48B 'cms':24B 'condit':49B 'cross':5A,42B,78C,89C 'cross-sit':4A,41B,77C,88C 'cve':14A,17A 'drupal':1A,25B,27B,31B,83C 'drupal-ai':26B 'drupal/ai':20A 'fix':63B 'format':58B 'generat':76C 'html':38B,62B 'improp':69C 'input':72C 'intellig':86C,98C 'issu':94C 'let':8A 'modul':3A,33B 'must':52B 'neutral':70C 'page':13A,75C 'php':29B 'possibl':46B 'render':39B,61B 'restrict':37B 'run':10A 'script':7A,11A,44B,80C,91C 'site':6A,43B,79C,90C 'suffici':36B 'text':57B 'tool':23B 'version':99C 'vulner':81C 'web':74C 'xss':92C","nicknames":[],"mitigations":[],"who_affected":"Drupal sites with the AI (Artificial Intelligence) module installed in a version below 1.4.11 (1.4.x) or below 1.5.2 (1.5.x), including unsupported 1.3.x. Exploiting it needs a user who can use a text format that renders HTML, so sites where only trusted staff have such formats face the least risk. Sites without the AI module can skip it.","tier":"B","verified":{"fix":{"at":"2026-10-30T04:30:54Z","by":"analyst","doc":"https://www.drupal.org/sa-contrib-2026-266","run_id":1126},"products":{"at":"2026-10-30T04:30:54Z","by":"analyst","doc":"https://www.drupal.org/sa-contrib-2026-266","run_id":1126},"how_to_check":{"at":"2026-10-30T04:30:54Z","by":"analyst","doc":"https://www.drupal.org/sa-contrib-2026-266","run_id":1126},"who_affected":{"at":"2026-10-30T04:30:54Z","by":"analyst","doc":"https://www.drupal.org/sa-contrib-2026-266","run_id":1126}},"analyst_revisit_at":null,"fix_status":"available","audience":"businesses","plain_action":null,"first_public_at":"2026-10-30T04:18:19+00:00","kev":null,"cvss_vector":null,"cvss_by":null,"poc_count":0,"sources":[{"source":"nvd","external_id":"CVE-2026-118545","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-118545","severity":null,"published_at":"2026-10-30T04:18:19+00:00","modified_at":"2026-10-30T04:18:19+00:00","first_seen_at":"2026-10-30T04:28:38+00:00","fetched_at":"2026-10-30T04:28:38+00:00","note":null},{"source":"analyst","external_id":"CVE-2026-118545:1126","url":null,"severity":null,"published_at":"2026-10-30T04:30:54+00:00","modified_at":"2026-10-30T04:30:54+00:00","first_seen_at":"2026-10-30T04:30:54+00:00","fetched_at":"2026-10-30T04:30:54+00:00","note":"Drupal SA-CONTRIB-2026-266 (moderately critical 14/25, 2026-10-28) read directly; fix is AI 1.4.11 or 1.5.2; 1.3.x unsupported. Needs a text format that renders HTML. Advisory says 'Theoretical' exploit; no exploitation or PoC found. Same release fixes 7 sibling AI SAs (267-273). Advisory range reads <1.4.11 and >=1.5.0 <1.5.2, so NVD's 'to 1.4.11' looks like an inclusive-boundary slip. Severity medium matches the vendor's 'moderately critical' rating."}],"documents":[{"id":21302,"url":"https://www.drupal.org/sa-contrib-2026-266","title":"SA-CONTRIB-2026-266 AI (Artificial Intelligence) - Cross-site scripting","kind":"advisory","source":"analyst","publisher":null,"text":null,"published_at":null,"relation":"advisory","confidence":null,"note":null}],"notice":"Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai"}