{"id":"CVE-2026-118101","kind":"vulnerability","aliases":["CVE-2026-118101"],"related":[],"title":"WordPress BuddyForms plugin lets low-privilege users overwrite others' posts","description":"The BuddyForms WordPress plugin before 2.10.1 does not verify that a user editing an existing entry is the author of the target post, allowing users who have been granted edit access to a form, as low as Subscriber, to overwrite the title, content and status of any other user's posts or pages, including those of administrators.","summary":"The BuddyForms WordPress plugin before 2.10.1 does not check that a user editing an existing form entry is its author. A user with edit access to a form, as low as Subscriber, can overwrite the title, content and status of any other user's posts or pages, including administrators'.","severity":"high","cvss":null,"epss":null,"exploited":false,"exploited_at":null,"products":[],"ecosystems":[],"tags":["buddyforms","package","self-hosted","wordpress"],"not_affected_if":["buddyforms-updated","no-form-edit-access"],"how_to_check":"- Check the installed BuddyForms plugin version in the WordPress admin under Plugins; versions below `2.10.1` are affected.\n- Confirm whether any form grants edit access to low-privilege roles such as Subscriber.","fix":"- BuddyForms: upgrade to `2.10.1` or later.","status":"open","published_at":"2026-10-30T06:16:46+00:00","first_seen_at":"2026-10-30T06:28:39+00:00","triaged_at":"2026-10-30T06:29:57+00:00","updated_at":"2026-10-30T06:29:57+00:00","category":"package","confidence":0.8,"triage":{"at":"2026-10-30T06:29:57Z","model":"claude-haiku-5-5","output":{"fix":"- BuddyForms: upgrade to `2.10.1` or later.","reach":"internet","title":"WordPress BuddyForms plugin lets low-privilege users overwrite others' posts","impact":"high","summary":"The BuddyForms WordPress plugin before 2.10.1 does not check that a user editing an existing form entry is its author. A user with edit access to a form, as low as Subscriber, can overwrite the title, content and status of any other user's posts or pages, including administrators'.","audience":"businesses","category":"package","nicknames":[],"who_cares":["wordpress","buddyforms","self-hosted"],"confidence":0.8,"fix_status":"available","needs_auth":"yes","worst_case":"low-privilege user overwrites administrator posts and pages on the site","analyst_note":"","how_to_check":"- Check the installed BuddyForms plugin version in the WordPress admin under Plugins; versions below `2.10.1` are affected.\n- Confirm whether any form grants edit access to low-privilege roles such as Subscriber.","plain_action":"","needs_analyst":false,"not_affected_if":["buddyforms-updated","no-form-edit-access"],"who_is_affected":"Sites running the BuddyForms plugin before 2.10.1 that let users edit existing form entries. Exposure depends on whether low-privilege roles such as Subscriber have edit access to a form. Sites without BuddyForms, or with it updated to 2.10.1 or later, are not affected.","user_interaction":"no","needs_special_setup":"yes","severity_if_unknown":"high"},"cost_usd":0.000685,"input_tokens":4119,"output_tokens":546,"severity_before":"unknown"},"analyst_status":null,"analyst_note":null,"search":"'-118101':14A,17A '-2026':13A,16A '2.10.1':29B,78C 'access':48B,103C 'administr':72B,129C 'allow':96C 'author':43B,91C 'buddyform':2A,18B,25B,74C 'check':32B 'content':60B,115C 'cve':12A,15A 'edit':36B,47B,85C,102C 'entri':40B,88C 'exist':38B,87C 'form':39B,51B,106C 'grant':101C 'host':22B 'includ':71B,126C 'let':4A 'low':6A,53B,108C 'low-privileg':5A 'other':10A 'overwrit':9A,57B,112C 'packag':19B 'page':70B,125C 'plugin':3A,27B,76C 'post':11A,68B,95C,123C 'privileg':7A 'self':21B 'self-host':20B 'status':62B,117C 'subscrib':55B,110C 'target':94C 'titl':59B,114C 'user':8A,35B,45B,66B,84C,97C,121C 'verifi':81C 'wordpress':1A,23B,26B,75C","nicknames":[],"mitigations":[],"who_affected":"Sites running the BuddyForms plugin before 2.10.1 that let users edit existing form entries. Exposure depends on whether low-privilege roles such as Subscriber have edit access to a form. Sites without BuddyForms, or with it updated to 2.10.1 or later, are not affected.","tier":"B","verified":{},"analyst_revisit_at":null,"fix_status":"available","audience":"businesses","plain_action":null,"first_public_at":"2026-10-30T06:16:46+00:00","kev":null,"cvss_vector":null,"cvss_by":null,"poc_count":0,"sources":[{"source":"nvd","external_id":"CVE-2026-118101","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-118101","severity":null,"published_at":"2026-10-30T06:16:46+00:00","modified_at":"2026-10-30T06:16:46+00:00","first_seen_at":"2026-10-30T06:28:39+00:00","fetched_at":"2026-10-30T06:28:39+00:00","note":null}],"documents":[],"notice":"Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai"}