{"id":"CVE-2026-118056","kind":"vulnerability","aliases":["CVE-2026-118056"],"related":[],"title":"Image Hover Effects Ultimate WordPress plugin: stored XSS via image comparison text","description":"The Image Hover Effects Ultimate ( Image Gallery, Effects, Lightbox, Comparison & Magnifier ) plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'rawdata.oxi_image_comparison_before_text' parameter in all versions up to, and including, 9.12.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is only exploitable when an administrator has configured the plugin's \"Who can edit\" setting to Subscriber, which allows any authenticated user to overwrite existing styles — including those created by administrators — via a missing ownership check on the target style ID.","summary":"The Image Hover Effects Ultimate WordPress plugin, up to and including 9.12.2, does not sanitize the rawdata.oxi_image_comparison_before_text parameter. An authenticated subscriber can store a script that runs in the browser of anyone who opens an affected page.","severity":"medium","cvss":4.9,"epss":null,"exploited":false,"exploited_at":null,"products":[],"ecosystems":[],"tags":["package","self-hosted","wordpress","wp-plugin"],"not_affected_if":["default-config","plugin-not-installed"],"how_to_check":"- Check the installed plugin version in the WordPress admin under Plugins; affected versions are `9.12.2` and below.\n- Check whether the plugin's \"Who can edit\" setting is set to Subscriber.","fix":"- Image Hover Effects Ultimate: move to a version later than `9.12.2`; the fixed version is not stated in the sources.","status":"open","published_at":"2026-11-07T12:17:43+00:00","first_seen_at":"2026-11-07T12:47:08+00:00","triaged_at":"2026-11-07T12:49:11+00:00","updated_at":"2026-11-07T12:49:11+00:00","category":"package","confidence":0.8,"triage":{"at":"2026-11-07T12:49:11Z","model":"claude-haiku-5-5","output":{"fix":"- Image Hover Effects Ultimate: move to a version later than `9.12.2`; the fixed version is not stated in the sources.","reach":"network","title":"Image Hover Effects Ultimate WordPress plugin: stored XSS via image comparison text","impact":"medium","summary":"The Image Hover Effects Ultimate WordPress plugin, up to and including 9.12.2, does not sanitize the rawdata.oxi_image_comparison_before_text parameter. An authenticated subscriber can store a script that runs in the browser of anyone who opens an affected page.","audience":"businesses","category":"package","nicknames":[],"who_cares":["wordpress","wp-plugin","self-hosted"],"confidence":0.8,"fix_status":"unknown","needs_auth":"yes","worst_case":"Scripts run in visitors' browsers, stealing sessions or altering pages","analyst_note":"Find the fixed plugin version after 9.12.2 from the NVD entry or the WordPress plugin changelog.","how_to_check":"- Check the installed plugin version in the WordPress admin under Plugins; affected versions are `9.12.2` and below.\n- Check whether the plugin's \"Who can edit\" setting is set to Subscriber.","plain_action":"","needs_analyst":true,"not_affected_if":["default-config","plugin-not-installed"],"who_is_affected":"Sites running the Image Hover Effects Ultimate plugin version 9.12.2 or earlier. The flaw is only exploitable when an administrator has set the plugin's \"Who can edit\" option to Subscriber, which lets subscribers overwrite styles. Sites that keep the default setting, or that do not run the plugin, are not exposed.","user_interaction":"yes","needs_special_setup":"yes","severity_if_unknown":"medium"},"cost_usd":0.000757,"input_tokens":4411,"output_tokens":631,"severity_before":"medium"},"analyst_status":null,"analyst_note":null,"search":"'-118056':15A,18A '-2026':14A,17A '9.12.2':38B,105C 'access':125C,141C 'administr':151C,176C 'affect':66B 'allow':164C 'anyon':62B 'arbitrari':130C 'attack':120C 'authent':50B,119C,166C 'browser':60B 'check':181C 'comparison':11A,45B,77C,94C 'configur':153C 'creat':174C 'cross':87C 'cross-sit':86C 'cve':13A,16A 'due':106C 'edit':159C 'effect':3A,30B,71C,75C 'escap':113C 'execut':137C 'exist':170C 'exploit':148C 'galleri':74C 'host':22B 'hover':2A,29B,70C 'id':186C 'imag':1A,10A,28B,44B,69C,73C,93C 'includ':37B,104C,172C 'inject':129C,143C 'input':109C 'insuffici':108C 'level':124C 'lightbox':76C 'magnifi':78C 'make':115C 'miss':179C 'open':64B 'output':112C 'overwrit':169C 'ownership':180C 'packag':19B 'page':67B,134C,144C 'paramet':48B,97C 'plugin':6A,26B,33B,79C,155C 'possibl':117C 'rawdata.oxi':43B,92C 'run':57B 'sanit':41B,110C 'script':55B,89C,132C 'self':21B 'self-host':20B 'set':160C 'site':88C 'store':7A,53B,85C 'style':171C,185C 'subscrib':51B,123C,162C 'subscriber-level':122C 'target':184C 'text':12A,47B,96C 'ultim':4A,31B,72C 'user':140C,167C 'version':100C 'via':9A,90C,177C 'vulner':83C 'web':131C 'whenev':138C 'wordpress':5A,23B,32B,81C 'wp':25B 'wp-plugin':24B 'xss':8A","nicknames":[],"mitigations":[],"who_affected":"Sites running the Image Hover Effects Ultimate plugin version 9.12.2 or earlier. The flaw is only exploitable when an administrator has set the plugin's \"Who can edit\" option to Subscriber, which lets subscribers overwrite styles. Sites that keep the default setting, or that do not run the plugin, are not exposed.","tier":"C","verified":{},"analyst_revisit_at":null,"fix_status":"unknown","audience":"businesses","plain_action":null,"pkeys":[],"ptokens":[],"labels":["medium","package","selfhosted","wordpress","wpplugin"],"campaign_type":null,"search_a":"'-118056':15A,18A '-2026':14A,17A 'comparison':11A 'cve':13A,16A 'effect':3A 'hover':2A 'imag':1A,10A 'plugin':6A 'store':7A 'text':12A 'ultim':4A 'via':9A 'wordpress':5A 'xss':8A","search_b":"'9.12.2':38B 'affect':66B 'anyon':62B 'authent':50B 'browser':60B 'comparison':45B 'effect':30B 'host':22B 'hover':29B 'imag':28B,44B 'includ':37B 'open':64B 'packag':19B 'page':67B 'paramet':48B 'plugin':26B,33B 'rawdata.oxi':43B 'run':57B 'sanit':41B 'script':55B 'self':21B 'self-host':20B 'store':53B 'subscrib':51B 'text':47B 'ultim':31B 'wordpress':23B,32B 'wp':25B 'wp-plugin':24B","search_c":"'9.12.2':105C 'access':125C,141C 'administr':151C,176C 'allow':164C 'arbitrari':130C 'attack':120C 'authent':119C,166C 'check':181C 'comparison':77C,94C 'configur':153C 'creat':174C 'cross':87C 'cross-sit':86C 'due':106C 'edit':159C 'effect':71C,75C 'escap':113C 'execut':137C 'exist':170C 'exploit':148C 'galleri':74C 'hover':70C 'id':186C 'imag':69C,73C,93C 'includ':104C,172C 'inject':129C,143C 'input':109C 'insuffici':108C 'level':124C 'lightbox':76C 'magnifi':78C 'make':115C 'miss':179C 'output':112C 'overwrit':169C 'ownership':180C 'page':134C,144C 'paramet':97C 'plugin':79C,155C 'possibl':117C 'rawdata.oxi':92C 'sanit':110C 'script':89C,132C 'set':160C 'site':88C 'store':85C 'style':171C,185C 'subscrib':123C,162C 'subscriber-level':122C 'target':184C 'text':96C 'ultim':72C 'user':140C,167C 'version':100C 'via':90C,177C 'vulner':83C 'web':131C 'whenev':138C 'wordpress':81C","first_public_at":"2026-11-07T12:17:43+00:00","kev":null,"cvss_vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:N","cvss_by":"security@wordfence.com","poc_count":0,"sources":[{"source":"nvd","external_id":"CVE-2026-118056","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-118056","severity":null,"published_at":"2026-11-07T12:17:43+00:00","modified_at":"2026-11-07T12:17:43+00:00","first_seen_at":"2026-11-07T12:47:08+00:00","fetched_at":"2026-11-07T12:47:08+00:00","note":null}],"documents":[],"exploit_sources":[],"notice":"Free to read, with fair use of about 60 pages a minute. For higher limits or API access: sales@infrastack.ai"}