---
id: "CVE-2026-116688"
kind: "vulnerability"
aliases: ["CVE-2026-116688", "GHSA-rh54-vffm-5fvp"]
title: "CKEditor: Cross-site scripting (XSS) in the engine package"
severity: "high"
cvss: 8.1
epss: null
exploited: false
status: "open"
category: "package"
products: [{"name": "ckeditor5", "fixed": ["47.7.4"], "affected": ">= 45.0.0, < 47.7.4", "ecosystem": "npm"}, {"name": "@ckeditor/ckeditor5-engine", "fixed": ["47.7.4"], "affected": ">= 45.0.0, < 47.7.4", "ecosystem": "npm"}, {"name": "ckeditor5", "fixed": ["48.5.1"], "affected": ">= 48.0.0, < 48.5.1", "ecosystem": "npm"}, {"name": "@ckeditor/ckeditor5-engine", "fixed": ["48.5.1"], "affected": ">= 48.0.0, < 48.5.1", "ecosystem": "npm"}]
ecosystems: ["npm"]
tags: ["ckeditor5", "cwe-79", "frontend", "javascript", "package", "rich-text"]
not_affected_if: ["no-user-supplied-content", "version-outside-range"]
published_at: "2026-10-27T20:17:14+00:00"
first_seen_at: "2026-10-27T20:33:27+00:00"
updated_at: "2026-10-27T21:09:20+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-116688", "first_seen_at": "2026-10-27T20:33:27+00:00"}, {"source": "ghsa", "url": "https://github.com/advisories/GHSA-rh54-vffm-5fvp", "first_seen_at": "2026-10-27T21:09:20+00:00"}]
---

# CKEditor: Cross-site scripting (XSS) in the engine package

CKEditor 5 uses a vulnerable es-toolkit version whose prototype pollution can be reached while the editor processes style attribute values. Crafted editor content can make the browser run unauthorized JavaScript.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- npm:ckeditor5 affected >= 45.0.0, < 47.7.4 fixed 47.7.4
- npm:@ckeditor/ckeditor5-engine affected >= 45.0.0, < 47.7.4 fixed 47.7.4
- npm:ckeditor5 affected >= 48.0.0, < 48.5.1 fixed 48.5.1
- npm:@ckeditor/ckeditor5-engine affected >= 48.0.0, < 48.5.1 fixed 48.5.1

## How to check

- Check the installed `ckeditor5` package version in `package.json` or the lockfile; affected versions are 45.0.0 up to 47.7.4 and 48.5.1.
- Check whether `es-toolkit` is pinned in the lockfile to a vulnerable version.

## Fix

- Upgrade `ckeditor5` to `47.7.4` or `48.5.1`, matching your major line.

## Timeline

- 2026-10-27T20:33:27+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-116688
- 2026-10-27T21:09:20+00:00 ghsa https://github.com/advisories/GHSA-rh54-vffm-5fvp

## From the sources

### Impact
A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability is caused by a prototype pollution issue in the `es-toolkit` library used in the CKEditor 5 codebase. This vulnerability could lead to unauthorized JavaScript code execution when the editor processes incoming `style` attribute values.

The underlying issue has been patched by the library maintainers, and the fix has been incorporated into CKEditor 5.

### Patches
The problem has been recognized and patched. The fix will be available in version `48.5.1` (and above) and `47.7.4` (LTS).

### For more information
Email us at [security@cksource.com](mailto:security@cksource.com) if you have any questions or comments about this advisory.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
