---
id: "CVE-2026-116687"
kind: "vulnerability"
aliases: ["CVE-2026-116687", "GHSA-v6mg-96c6-gmpq"]
title: "CKEditor: Cross-site scripting (XSS) in the engine package"
severity: "low"
cvss: 3.1
epss: null
exploited: false
status: "open"
category: "package"
products: [{"name": "ckeditor5", "fixed": ["47.7.4"], "affected": ">= 29.0.0, < 47.7.4", "ecosystem": "npm"}, {"name": "@ckeditor/ckeditor5-engine", "fixed": ["47.7.4"], "affected": ">= 29.0.0, < 47.7.4", "ecosystem": "npm"}, {"name": "ckeditor5", "fixed": ["48.5.1"], "affected": ">= 48.0.0, < 48.5.1", "ecosystem": "npm"}, {"name": "@ckeditor/ckeditor5-engine", "fixed": ["48.5.1"], "affected": ">= 48.0.0, < 48.5.1", "ecosystem": "npm"}]
ecosystems: ["npm"]
tags: ["ckeditor5", "cwe-79", "javascript", "package", "rich-text-editor"]
not_affected_if: ["default-config", "ghs-object-not-allowed"]
published_at: "2026-10-27T20:17:13+00:00"
first_seen_at: "2026-10-27T20:33:27+00:00"
updated_at: "2026-10-27T21:09:20+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-116687", "first_seen_at": "2026-10-27T20:33:27+00:00"}, {"source": "ghsa", "url": "https://github.com/advisories/GHSA-v6mg-96c6-gmpq", "first_seen_at": "2026-10-27T21:09:20+00:00"}]
---

# CKEditor: Cross-site scripting (XSS) in the engine package

CKEditor 5 from 29.0.0 up to 47.7.4 and 48.5.1 can execute attacker-supplied JavaScript when General HTML Support is enabled and configured to allow object content. The script runs in a browser context isolated from the embedding application's origin.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- npm:ckeditor5 affected >= 29.0.0, < 47.7.4 fixed 47.7.4
- npm:@ckeditor/ckeditor5-engine affected >= 29.0.0, < 47.7.4 fixed 47.7.4
- npm:ckeditor5 affected >= 48.0.0, < 48.5.1 fixed 48.5.1
- npm:@ckeditor/ckeditor5-engine affected >= 48.0.0, < 48.5.1 fixed 48.5.1

## How to check

- Check the installed `ckeditor5` package version in `package.json` and lockfile against `47.7.4` / `48.5.1`
- Search editor configuration for General HTML Support settings that allow `object` elements

## Fix

- Upgrade `ckeditor5` to `47.7.4` or `48.5.1`, matching your major line

## Timeline

- 2026-10-27T20:33:27+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-116687
- 2026-10-27T21:09:20+00:00 ghsa https://github.com/advisories/GHSA-v6mg-96c6-gmpq

## From the sources

### Impact
A Cross-Site Scripting (XSS) vulnerability has been discovered in the CKEditor 5 engine. This vulnerability could be triggered by inserting specially crafted markup under a specific General HTML Support configuration that allows inserting objects, leading to unauthorized JavaScript code execution in a browser context isolated from the origin of the application embedding the editor.

This vulnerability affects only installations where General HTML Support is enabled and configured to allow the affected HTML content.

### Patches
The problem has been recognized and patched. The fix will be available in version `48.5.1` (and above) and `47.7.4` (LTS).

### For more information
Email us at [security@cksource.com](mailto:security@cksource.com) if you have any questions or comments about this advisory.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
