ADVANCED-MEMBERS · CVE-2026-116624 · Package
FIX → 1.3.1 ✓ verified
The Advanced Members for ACF WordPress plugin, up to and including 1.3.0, has a privilege escalation flaw in its account password form. A logged-in user with only Subscriber access can overwrite the password of user ID 1, the primary administrator, and so gain full admin control of the site.
first public Nov 6, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
Sites running the Advanced Members for ACF plugin up to and including 1.3.0 that use the account password shortcode form, where any registered user can submit it. Sites without this plugin, or without the shortcode form, are not exposed. The sources do not state a fixed version.
Not affected if plugin-not-installed, shortcode-not-used
Who cares advanced-members-for-acf, self-hosted, wordpress
Upgrade to 1.3.1
1.3.1 or later (changelog: )The Advanced Members for ACF plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 1.3.0 via the acf[_amem_local_user_password] parameter of the [advanced-members-account-password] shortcode form submission. This is due to a PHP operator-precedence bug in the pre_update_value function of acf/fields/class-user-password.php that assigns boolean true instead of the resolved user ID to $user_id, causing the _can_edit() authorization check to pass for any logged-in user via PHP loose equality, and causing wp_update_user() to cast 'ID' => true to integer 1 — unconditionally targeting the primary administrator account. This makes it possible for authenticated attackers, with Subscriber-level access and above, to overwrite the password of user ID 1 (the site's primary administrator) with an attacker-chosen value, granting full administrative access to the site. The intended exclusion guard in Account::process that strips the password field before saving is defeated because re-reads the full field list from and silently overwrites the caller-supplied excluded fields array with an empty array, ensuring the password field is always processed.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
Security: Fixed a password update vulnerabilityamem_save_all_fields()amem()->submissionThis page as .md · .json · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.