{"id":"CVE-2026-116107","kind":"vulnerability","aliases":["CVE-2026-116107"],"related":[],"title":"Datafeedr Product Sets WordPress plugin: missing authorization on saved-search deletion","description":"A vulnerability was detected in Datafeedr Product Sets Plugin up to 1.3.24 on WordPress. Affected by this issue is the function dfrps_ajax_delete_saved_search of the file functions/ajax.php of the component AJAX Handlers. The manipulation results in missing authorization. The attack may be launched remotely. The exploit is now public and may be used. Upgrading to version 1.3.25 can resolve this issue. Upgrading the affected component is advised. The vendor was contacted early about this disclosure.","summary":"The Datafeedr Product Sets plugin for WordPress up to version 1.3.24 has an AJAX handler that deletes saved searches without checking authorization. A remote attacker can trigger the deletion of saved searches, and a public exploit exists.","severity":"medium","cvss":5.5,"epss":null,"exploited":false,"exploited_at":null,"products":[],"ecosystems":[],"tags":["package","wordpress","wordpress-plugin"],"not_affected_if":["plugin-not-installed","plugin-version-1.3.25-or-later"],"how_to_check":"- Check the installed plugin version in the WordPress admin under Plugins, or with `wp plugin get datafeedr-product-sets` if WP-CLI is available\n- Look for the function `dfrps_ajax_delete_saved_search` in `functions/ajax.php` of the plugin","fix":"- Update the Datafeedr Product Sets plugin to `1.3.25` or later","status":"open","published_at":"2026-10-26T02:17:06+00:00","first_seen_at":"2026-10-26T02:39:11+00:00","triaged_at":"2026-10-26T02:39:35+00:00","updated_at":"2026-10-26T02:39:35+00:00","category":"package","confidence":0.6,"triage":{"at":"2026-10-26T02:39:35Z","model":"claude-haiku-5-5","output":{"fix":"- Update the Datafeedr Product Sets plugin to `1.3.25` or later","reach":"internet","title":"Datafeedr Product Sets WordPress plugin: missing authorization on saved-search deletion","impact":"low","summary":"The Datafeedr Product Sets plugin for WordPress up to version 1.3.24 has an AJAX handler that deletes saved searches without checking authorization. A remote attacker can trigger the deletion of saved searches, and a public exploit exists.","category":"package","nicknames":[],"who_cares":["wordpress","wordpress-plugin"],"confidence":0.6,"needs_auth":"unknown","worst_case":"Saved searches can be deleted by unauthorized remote users","analyst_note":"","how_to_check":"- Check the installed plugin version in the WordPress admin under Plugins, or with `wp plugin get datafeedr-product-sets` if WP-CLI is available\n- Look for the function `dfrps_ajax_delete_saved_search` in `functions/ajax.php` of the plugin","needs_analyst":false,"not_affected_if":["plugin-not-installed","plugin-version-1.3.25-or-later"],"who_is_affected":"Sites running the Datafeedr Product Sets plugin at version 1.3.24 or earlier are exposed, because the saved-search deletion endpoint lacks an authorization check and can be reached remotely. Sites that do not have this plugin installed are not affected.","user_interaction":"no","needs_special_setup":"unknown","severity_if_unknown":"medium"},"cost_usd":0.000609,"input_tokens":3395,"output_tokens":539,"severity_before":"medium"},"analyst_status":null,"analyst_note":null,"search":"'-116107':15A,18A '-2026':14A,17A '1.3.24':34B,72C '1.3.25':120C 'advis':130C 'affect':75C,127C 'ajax':37B,83C,94C 'attack':48B,103C 'author':7A,45B,101C 'check':44B 'compon':93C,128C 'contact':134C 'cve':13A,16A 'datafeedr':1A,25B,66C 'delet':12A,40B,52B,84C 'detect':64C 'dfrps':82C 'disclosur':138C 'earli':135C 'exist':60B 'exploit':59B,109C 'file':89C 'function':81C 'functions/ajax.php':90C 'handler':38B,95C 'issu':78C,124C 'launch':106C 'manipul':97C 'may':104C,114C 'miss':6A,100C 'packag':19B 'plugin':5A,23B,28B,69C 'product':2A,26B,67C 'public':58B,112C 'remot':47B,107C 'resolv':122C 'result':98C 'save':10A,41B,54B,85C 'saved-search':9A 'search':11A,42B,55B,86C 'set':3A,27B,68C 'trigger':50B 'upgrad':117C,125C 'use':116C 'vendor':132C 'version':33B,119C 'vulner':62C 'without':43B 'wordpress':4A,20B,22B,30B,74C 'wordpress-plugin':21B","nicknames":[],"mitigations":[],"who_affected":"Sites running the Datafeedr Product Sets plugin at version 1.3.24 or earlier are exposed, because the saved-search deletion endpoint lacks an authorization check and can be reached remotely. Sites that do not have this plugin installed are not affected.","tier":"C","verified":{},"analyst_revisit_at":null,"first_public_at":"2026-10-26T02:17:06+00:00","kev":null,"cvss_vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X","cvss_by":"cna@vuldb.com","poc_count":0,"sources":[{"source":"nvd","external_id":"CVE-2026-116107","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-116107","severity":null,"published_at":"2026-10-26T02:17:06+00:00","modified_at":"2026-10-26T02:17:06+00:00","first_seen_at":"2026-10-26T02:39:11+00:00","fetched_at":"2026-10-26T02:39:11+00:00","note":null}],"documents":[],"notice":"Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai"}