---
id: "CVE-2026-115915"
kind: "vulnerability"
aliases: ["CVE-2026-115915"]
title: "vLLM: crafted image input can reach Ghostscript and run commands"
severity: "high"
cvss: 8.1
epss: null
exploited: false
status: "open"
category: "ai-tooling"
products: []
ecosystems: []
tags: ["ai-tooling", "llm-serving", "python", "self-hosted", "vllm"]
not_affected_if: ["no-ghostscript", "no-image-inputs", "vllm-0.32.0-or-later"]
published_at: "2026-10-26T18:17:38+00:00"
first_seen_at: "2026-10-26T18:31:43+00:00"
updated_at: "2026-10-26T18:33:46+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-115915", "first_seen_at": "2026-10-26T18:31:43+00:00"}]
---

# vLLM: crafted image input can reach Ghostscript and run commands

vLLM passes attacker-supplied image bytes to Pillow without restricting which decoder runs, so an EPS payload can be dispatched through image request paths. On a host with a vulnerable Ghostscript, the payload can run commands with the vLLM process's privileges.

_Summary, check and fix written by a model from the sources; labelled as such._

## How to check

- Check the installed vLLM version with `pip show vllm` and compare against `0.32.0`.
- Check whether Ghostscript is installed with `gs --version` and whether it is affected by CVE-2024-29510.
- Check the Pillow version with `pip show pillow`; versions `12.0.0` through `12.2.0` are also named in the sources.

## Fix

- Upgrade vLLM to `0.32.0` or later.
- Upgrade or remove Ghostscript if it is affected by CVE-2024-29510, per your distribution's advisory.
- Upgrade Pillow past `12.2.0` if you run a version in that range (fixed version unknown from sources).

## Timeline

- 2026-10-26T18:31:43+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-115915

## From the sources

vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
