{"id":"CVE-2026-115915","kind":"vulnerability","aliases":["CVE-2026-115915"],"related":[],"title":"vLLM: crafted image input can reach Ghostscript and run commands","description":"vLLM is an inference and serving engine for large language models. Prior to 0.32.0, ImageMediaIO passes attacker-controlled image bytes to Pillow through Image.open(BytesIO(data)) without restricting decoder selection, and the MIME label does not constrain the selected format. Image-capable request paths through parse_image() and fetch_image() can therefore dispatch an EPS payload to host components. A host with Ghostscript affected by CVE-2024-29510 can execute commands with the vLLM process's privileges, while environments using Pillow 12.0.0 through 12.2.0 can trigger CVE-2026-59203 and exhaust media-loading workers. Deployments without the applicable vulnerable dependency are not affected by that corresponding impact. This issue is fixed in version 0.32.0.","summary":"vLLM passes attacker-supplied image bytes to Pillow without restricting which decoder runs, so an EPS payload can be dispatched through image request paths. On a host with a vulnerable Ghostscript, the payload can run commands with the vLLM process's privileges.","severity":"high","cvss":8.1,"epss":null,"exploited":false,"exploited_at":null,"products":[],"ecosystems":[],"tags":["ai-tooling","llm-serving","python","self-hosted","vllm"],"not_affected_if":["no-ghostscript","no-image-inputs","vllm-0.32.0-or-later"],"how_to_check":"- Check the installed vLLM version with `pip show vllm` and compare against `0.32.0`.\n- Check whether Ghostscript is installed with `gs --version` and whether it is affected by CVE-2024-29510.\n- Check the Pillow version with `pip show pillow`; versions `12.0.0` through `12.2.0` are also named in the sources.","fix":"- Upgrade vLLM to `0.32.0` or later.\n- Upgrade or remove Ghostscript if it is affected by CVE-2024-29510, per your distribution's advisory.\n- Upgrade Pillow past `12.2.0` if you run a version in that range (fixed version unknown from sources).","status":"open","published_at":"2026-10-26T18:17:38+00:00","first_seen_at":"2026-10-26T18:31:43+00:00","triaged_at":"2026-10-26T18:33:46+00:00","updated_at":"2026-10-26T18:33:46+00:00","category":"ai-tooling","confidence":0.7,"triage":{"at":"2026-10-26T18:33:46Z","model":"claude-haiku-5-5","output":{"fix":"- Upgrade vLLM to `0.32.0` or later.\n- Upgrade or remove Ghostscript if it is affected by CVE-2024-29510, per your distribution's advisory.\n- Upgrade Pillow past `12.2.0` if you run a version in that range (fixed version unknown from sources).","reach":"internet","title":"vLLM: crafted image input can reach Ghostscript and run commands","impact":"high","summary":"vLLM passes attacker-supplied image bytes to Pillow without restricting which decoder runs, so an EPS payload can be dispatched through image request paths. On a host with a vulnerable Ghostscript, the payload can run commands with the vLLM process's privileges.","category":"ai-tooling","nicknames":[],"who_cares":["vllm","python","self-hosted","llm-serving"],"confidence":0.7,"needs_auth":"unknown","worst_case":"Commands run as the vLLM process user on the serving host.","analyst_note":"Check the NVD entry and the vLLM 0.32.0 release notes to confirm whether unauthenticated image requests reach the vulnerable path by default.","how_to_check":"- Check the installed vLLM version with `pip show vllm` and compare against `0.32.0`.\n- Check whether Ghostscript is installed with `gs --version` and whether it is affected by CVE-2024-29510.\n- Check the Pillow version with `pip show pillow`; versions `12.0.0` through `12.2.0` are also named in the sources.","needs_analyst":true,"not_affected_if":["vllm-0.32.0-or-later","no-image-inputs","no-ghostscript"],"who_is_affected":"Deployments running vLLM before 0.32.0 that accept image inputs through request paths such as parse_image() or fetch_image() are exposed. The command-execution impact requires a host with Ghostscript affected by CVE-2024-29510; the worker exhaustion impact requires Pillow 12.0.0 through 12.2.0. Deployments without the vulnerable dependency are not affected by that corresponding impact.","user_interaction":"no","needs_special_setup":"unknown","severity_if_unknown":"high"},"cost_usd":0.000722,"input_tokens":3465,"output_tokens":750,"severity_before":"high"},"analyst_status":null,"analyst_note":null,"search":"'-115915':13A,16A '-2024':139C '-2026':12A,15A,160C '-29510':140C '-59203':161C '0.32.0':84C,187C '12.0.0':154C '12.2.0':156C 'affect':136C,176C 'ai':18B 'ai-tool':17B 'applic':171C 'attack':31B,88C 'attacker-control':87C 'attacker-suppli':30B 'byte':34B,91C 'bytesio':96C 'capabl':114C 'command':10A,64B,143C 'compon':131C 'constrain':108C 'control':89C 'correspond':179C 'craft':2A 'cve':11A,14A,138C,159C 'data':97C 'decod':40B,100C 'depend':173C 'deploy':168C 'dispatch':48B,125C 'engin':77C 'environ':151C 'ep':44B,127C 'execut':142C 'exhaust':163C 'fetch':121C 'fix':184C 'format':111C 'ghostscript':7A,59B,135C 'host':26B,55B,130C,133C 'imag':3A,33B,50B,90C,113C,119C,122C 'image-cap':112C 'image.open':95C 'imagemediaio':85C 'impact':180C 'infer':74C 'input':4A 'issu':182C 'label':105C 'languag':80C 'larg':79C 'llm':21B 'llm-serv':20B 'load':166C 'media':165C 'media-load':164C 'mime':104C 'model':81C 'pars':118C 'pass':29B,86C 'path':52B,116C 'payload':45B,61B,128C 'pillow':36B,93C,153C 'prior':82C 'privileg':70B,149C 'process':68B,147C 'python':23B 'reach':6A 'request':51B,115C 'restrict':38B,99C 'run':9A,41B,63B 'select':101C,110C 'self':25B 'self-host':24B 'serv':22B,76C 'suppli':32B 'therefor':124C 'tool':19B 'trigger':158C 'use':152C 'version':186C 'vllm':1A,27B,28B,67B,71C,146C 'vulner':58B,172C 'without':37B,98C,169C 'worker':167C","nicknames":[],"mitigations":[],"who_affected":"Deployments running vLLM before 0.32.0 that accept image inputs through request paths such as parse_image() or fetch_image() are exposed. The command-execution impact requires a host with Ghostscript affected by CVE-2024-29510; the worker exhaustion impact requires Pillow 12.0.0 through 12.2.0. Deployments without the vulnerable dependency are not affected by that corresponding impact.","tier":"B","verified":{},"analyst_revisit_at":null,"first_public_at":"2026-10-26T18:17:38+00:00","kev":null,"cvss_vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","cvss_by":"security-advisories@github.com","poc_count":0,"sources":[{"source":"nvd","external_id":"CVE-2026-115915","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-115915","severity":null,"published_at":"2026-10-26T18:17:38+00:00","modified_at":"2026-10-26T18:17:38+00:00","first_seen_at":"2026-10-26T18:31:43+00:00","fetched_at":"2026-10-26T18:31:43+00:00","note":null}],"documents":[],"notice":"Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai"}