{"id":"CVE-2026-115425","kind":"vulnerability","aliases":["CVE-2026-115425"],"related":[],"title":"OPNsense firewall: multiple XSS flaws let low-privileged users run script","description":"Multiple cross site scripting (XSS) vulnerabilities affect OPNsense firewall vesrion 26.7.1_1 and earlier allows low privileged attacker to execute Javascript in the context of another user visiting a specific page or clicking on a specifically crafted link.","summary":"Several cross-site scripting flaws in OPNsense firewall version 26.7.1_1 and earlier let a low-privileged user inject JavaScript. When another user visits a crafted page or clicks a crafted link, that script runs in their browser session.","severity":"medium","cvss":5.6,"epss":null,"exploited":false,"exploited_at":null,"products":[],"ecosystems":[],"tags":["firewall","infrastructure","opnsense","self-hosted"],"not_affected_if":["default-config"],"how_to_check":"- Run `opnsense-version` on the firewall (or check System > Firmware > Status) and compare against `26.7.1_1`\n- Check whether any admin accounts with limited privileges are used to view the web UI","fix":"- Upgrade OPNsense to a release later than `26.7.1_1`; the exact fixed version is unknown from the sources","status":"open","published_at":"2026-10-26T09:16:34+00:00","first_seen_at":"2026-10-26T09:29:15+00:00","triaged_at":"2026-10-26T09:30:56+00:00","updated_at":"2026-10-26T09:30:56+00:00","category":"infrastructure","confidence":0.5,"triage":{"at":"2026-10-26T09:30:56Z","model":"claude-haiku-5-5","output":{"fix":"- Upgrade OPNsense to a release later than `26.7.1_1`; the exact fixed version is unknown from the sources","reach":"network","title":"OPNsense firewall: multiple XSS flaws let low-privileged users run script","impact":"medium","summary":"Several cross-site scripting flaws in OPNsense firewall version 26.7.1_1 and earlier let a low-privileged user inject JavaScript. When another user visits a crafted page or clicks a crafted link, that script runs in their browser session.","category":"infrastructure","nicknames":[],"who_cares":["opnsense","firewall","self-hosted"],"confidence":0.5,"needs_auth":"yes","worst_case":"Attacker runs scripts in an admin's firewall web session","analyst_note":"Check the OPNsense security advisory for the fixed version number and the list of affected pages; the NVD entry alone does not give them.","how_to_check":"- Run `opnsense-version` on the firewall (or check System > Firmware > Status) and compare against `26.7.1_1`\n- Check whether any admin accounts with limited privileges are used to view the web UI","needs_analyst":true,"not_affected_if":["default-config"],"who_is_affected":"Any OPNsense firewall running version 26.7.1_1 or earlier is potentially exposed, especially where several users with different privilege levels use the web interface. Exposure depends on users being lured into visiting a crafted page while logged in, so teams with a single administrator on a locked-down management network have less immediate risk. Installations already on a later release are not affected.","user_interaction":"yes","needs_special_setup":"unknown","severity_if_unknown":"medium"},"cost_usd":0.00062,"input_tokens":3325,"output_tokens":574,"severity_before":"medium"},"analyst_status":null,"analyst_note":null,"search":"'-115425':15A,18A '-2026':14A,17A '1':36B,77C '26.7.1':35B,76C 'affect':72C 'allow':80C 'anoth':48B,91C 'attack':83C 'browser':64B 'click':55B,98C 'context':89C 'craft':52B,57B,102C 'cross':27B,67C 'cross-sit':26B 'cve':13A,16A 'earlier':38B,79C 'execut':85C 'firewal':2A,19B,33B,74C 'flaw':5A,30B 'host':24B 'infrastructur':20B 'inject':45B 'javascript':46B,86C 'let':6A,39B 'link':58B,103C 'low':8A,42B,81C 'low-privileg':7A,41B 'multipl':3A,66C 'opnsens':1A,21B,32B,73C 'page':53B,96C 'privileg':9A,43B,82C 'run':11A,61B 'script':12A,29B,60B,69C 'self':23B 'self-host':22B 'session':65B 'sever':25B 'site':28B,68C 'specif':95C,101C 'user':10A,44B,49B,92C 'version':34B 'vesrion':75C 'visit':50B,93C 'vulner':71C 'xss':4A,70C","nicknames":[],"mitigations":[],"who_affected":"Any OPNsense firewall running version 26.7.1_1 or earlier is potentially exposed, especially where several users with different privilege levels use the web interface. Exposure depends on users being lured into visiting a crafted page while logged in, so teams with a single administrator on a locked-down management network have less immediate risk. Installations already on a later release are not affected.","tier":"C","verified":{},"analyst_revisit_at":null,"first_public_at":"2026-10-26T09:16:34+00:00","kev":null,"cvss_vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H/E:P/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:P/AU:Y/R:I/V:C/RE:M/U:Amber","cvss_by":"vulnerability@ncsc.ch","poc_count":0,"sources":[{"source":"nvd","external_id":"CVE-2026-115425","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-115425","severity":null,"published_at":"2026-10-26T09:16:34+00:00","modified_at":"2026-10-26T09:16:34+00:00","first_seen_at":"2026-10-26T09:29:15+00:00","fetched_at":"2026-10-26T09:29:15+00:00","note":null}],"documents":[],"notice":"Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai"}