{"id":"CVE-2026-114709","kind":"vulnerability","aliases":["CVE-2026-114709"],"related":[],"title":"Ad Inserter WordPress plugin: reflected XSS through 2.8.18","description":"Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Igor Funa Ad Inserter ad-inserter allows Reflected XSS.This issue affects Ad Inserter: from n/a through 2.8.18.","summary":"Ad Inserter, a WordPress plugin by Igor Funa, does not neutralize some input before putting it into a web page, enabling reflected cross-site scripting. An attacker who tricks a logged-in user into opening a crafted link can run script in that user's browser session.","severity":"medium","cvss":6.5,"epss":null,"exploited":false,"exploited_at":null,"products":[],"ecosystems":[],"tags":["package","self-hosted","wordpress","wordpress-plugin"],"not_affected_if":["plugin-not-installed","version-above-2.8.18"],"how_to_check":"- Check the installed Ad Inserter version in the WordPress admin under Plugins, or with `wp plugin get ad-inserter --field=version`\n- Compare against the affected range: versions through `2.8.18`","fix":"- Update Ad Inserter to a version later than `2.8.18` (fixed version unknown from sources; check the plugin's WordPress.org changelog)\n- If no fixed version is available, deactivate the plugin until it is","status":"open","published_at":"2026-10-26T10:16:51+00:00","first_seen_at":"2026-10-26T10:29:17+00:00","triaged_at":"2026-10-26T10:30:51+00:00","updated_at":"2026-10-26T10:30:51+00:00","category":"package","confidence":0.6,"triage":{"at":"2026-10-26T10:30:51Z","model":"claude-haiku-5-5","output":{"fix":"- Update Ad Inserter to a version later than `2.8.18` (fixed version unknown from sources; check the plugin's WordPress.org changelog)\n- If no fixed version is available, deactivate the plugin until it is","reach":"internet","title":"Ad Inserter WordPress plugin: reflected XSS through 2.8.18","impact":"medium","summary":"Ad Inserter, a WordPress plugin by Igor Funa, does not neutralize some input before putting it into a web page, enabling reflected cross-site scripting. An attacker who tricks a logged-in user into opening a crafted link can run script in that user's browser session.","category":"package","nicknames":[],"who_cares":["wordpress","wordpress-plugin","self-hosted"],"confidence":0.6,"needs_auth":"unknown","worst_case":"Script runs in victim's browser session on the site","analyst_note":"Find the fixed version and the vulnerable parameter or page from the NVD entry and the plugin's WordPress.org changelog; confirm whether it needs an authenticated admin.","how_to_check":"- Check the installed Ad Inserter version in the WordPress admin under Plugins, or with `wp plugin get ad-inserter --field=version`\n- Compare against the affected range: versions through `2.8.18`","needs_analyst":true,"not_affected_if":["plugin-not-installed","version-above-2.8.18"],"who_is_affected":"Sites running the Ad Inserter plugin at version 2.8.18 or earlier. Exposure depends on whether the vulnerable parameter is reachable by a visitor; the sources do not say which parameter or page is affected. Sites that do not run this plugin can skip it.","user_interaction":"yes","needs_special_setup":"unknown","severity_if_unknown":"unknown"},"cost_usd":0.000642,"input_tokens":3318,"output_tokens":621,"severity_before":"medium"},"analyst_status":null,"analyst_note":null,"search":"'-114709':11A,14A '-2026':10A,13A '2.8.18':8A,103C 'ad':1A,23B,88C,91C,98C 'ad-insert':90C 'affect':97C 'allow':93C 'attack':50B 'browser':70B 'craft':61B 'cross':46B,81C 'cross-sit':45B,80C 'cve':9A,12A 'enabl':43B 'funa':30B,87C 'generat':79C 'host':18B 'igor':29B,86C 'improp':72C 'input':35B,75C 'insert':2A,24B,89C,92C,99C 'issu':96C 'link':62B 'log':55B 'logged-in':54B 'n/a':101C 'neutral':33B,73C 'open':59B 'packag':15B 'page':42B,78C 'plugin':4A,22B,27B 'put':37B 'reflect':5A,44B,94C 'run':64B 'script':48B,65B,83C 'self':17B 'self-host':16B 'session':71B 'site':47B,82C 'trick':52B 'user':57B,68B 'vulner':84C 'web':41B,77C 'wordpress':3A,19B,21B,26B 'wordpress-plugin':20B 'xss':6A 'xss.this':95C","nicknames":[],"mitigations":[],"who_affected":"Sites running the Ad Inserter plugin at version 2.8.18 or earlier. Exposure depends on whether the vulnerable parameter is reachable by a visitor; the sources do not say which parameter or page is affected. Sites that do not run this plugin can skip it.","tier":"C","verified":{},"analyst_revisit_at":null,"first_public_at":"2026-10-26T10:16:51+00:00","kev":null,"cvss_vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:L","cvss_by":"audit@patchstack.com","poc_count":0,"sources":[{"source":"nvd","external_id":"CVE-2026-114709","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-114709","severity":null,"published_at":"2026-10-26T10:16:51+00:00","modified_at":"2026-10-26T10:16:51+00:00","first_seen_at":"2026-10-26T10:29:17+00:00","fetched_at":"2026-10-26T10:29:17+00:00","note":null}],"documents":[],"notice":"Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai"}