{"id":"CVE-2026-109370","kind":"vulnerability","aliases":["CVE-2026-109370"],"related":[],"title":"WordPress Document Embedder plugin: stored XSS via embedded document download","description":"The Document Embedder – let visitors read files without downloading plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the 'content (post_content containing block JSON documentSource.doc)' parameter in all versions up to, and including, 2.4.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The payload is triggered specifically when the victim clicks the embedded document's Download button, which causes the de_track_download AJAX fallback path to programmatically create an anchor with the attacker-controlled href and call .click() — a condition reached because supplying docId=0 causes can_read_document() to return false, bypassing the normal download flow.","summary":"The Document Embedder WordPress plugin up to and including 2.4.0 does not sanitize block JSON in post content, so a contributor can store a malicious link. When a visitor clicks the embedded document's Download button, attacker script runs in their browser.","severity":"medium","cvss":6.4,"epss":null,"exploited":false,"exploited_at":null,"products":[],"ecosystems":[],"tags":["package","self-hosted","wordpress","wordpress-plugins"],"not_affected_if":["auth-required","only-trusted-editors","plugin-not-installed"],"how_to_check":"- Check the installed Document Embedder plugin version in the WordPress admin Plugins screen or `wp plugin get document-embedder --field=version`\n- Review pages that embed documents for unexpected script or link values in block JSON `documentSource.doc`","fix":"- Update the Document Embedder plugin to a version newer than `2.4.0` once a patched release is listed in the sources (the sources do not name one: unknown)\n- Until patched, remove or disable the plugin's download embeds on untrusted content","status":"open","published_at":"2026-10-28T07:16:44+00:00","first_seen_at":"2026-10-28T07:31:37+00:00","triaged_at":"2026-10-28T07:33:06+00:00","updated_at":"2026-10-28T07:33:06+00:00","category":"package","confidence":0.7,"triage":{"at":"2026-10-28T07:33:06Z","model":"claude-haiku-5-5","output":{"fix":"- Update the Document Embedder plugin to a version newer than `2.4.0` once a patched release is listed in the sources (the sources do not name one: unknown)\n- Until patched, remove or disable the plugin's download embeds on untrusted content","reach":"internet","title":"WordPress Document Embedder plugin: stored XSS via embedded document download","impact":"medium","summary":"The Document Embedder WordPress plugin up to and including 2.4.0 does not sanitize block JSON in post content, so a contributor can store a malicious link. When a visitor clicks the embedded document's Download button, attacker script runs in their browser.","category":"package","nicknames":[],"who_cares":["wordpress","wordpress-plugins","self-hosted"],"confidence":0.7,"needs_auth":"yes","worst_case":"Attacker script runs in visitors' browsers on the site","analyst_note":"Check NVD and the plugin's changelog for the patched version after 2.4.0 and confirm the exact fix.","how_to_check":"- Check the installed Document Embedder plugin version in the WordPress admin Plugins screen or `wp plugin get document-embedder --field=version`\n- Review pages that embed documents for unexpected script or link values in block JSON `documentSource.doc`","needs_analyst":true,"not_affected_if":["plugin-not-installed","only-trusted-editors","auth-required"],"who_is_affected":"Sites running Document Embedder `2.4.0` or earlier where contributors or higher can publish or edit pages with embedded documents. Visitors to those pages are the victims. Sites without the plugin, or where only trusted editors write content, have lower exposure.","user_interaction":"yes","needs_special_setup":"no","severity_if_unknown":"medium"},"cost_usd":0.000653,"input_tokens":3494,"output_tokens":607,"severity_before":"medium"},"analyst_status":null,"analyst_note":null,"search":"'-109370':13A,16A '-2026':12A,15A '0':191C '2.4.0':34B,107C 'access':127C,143C 'ajax':168C 'anchor':175C 'arbitrari':132C 'attack':61B,122C,179C 'attacker-control':178C 'authent':121C 'base':85C 'block':38B,96C 'browser':66B 'button':60B,161C 'bypass':199C 'call':183C 'caus':163C,192C 'click':54B,155C,184C 'condit':186C 'contain':95C 'content':42B,92C,94C 'contributor':45B,125C 'contributor-level':124C 'control':180C 'creat':173C 'cross':87C 'cross-sit':86C 'cve':11A,14A 'de':165C 'docid':190C 'document':2A,9A,26B,57B,68C,158C,195C 'documentsource.doc':98C 'dom':84C 'dom-bas':83C 'download':10A,59B,75C,160C,167C,202C 'due':108C 'embed':8A,56B,157C 'embedd':3A,27B,69C 'escap':115C 'execut':139C 'fallback':169C 'fals':198C 'file':73C 'flow':203C 'host':20B 'href':181C 'includ':33B,106C 'inject':131C,145C 'input':111C 'insuffici':110C 'json':39B,97C 'let':70C 'level':126C 'link':50B 'make':117C 'malici':49B 'normal':201C 'output':114C 'packag':17B 'page':136C,146C 'paramet':99C 'path':170C 'payload':148C 'plugin':4A,24B,29B,76C 'possibl':119C 'post':41B,93C 'programmat':172C 'reach':187C 'read':72C,194C 'return':197C 'run':63B 'sanit':37B,112C 'script':62B,89C,134C 'self':19B 'self-host':18B 'site':88C 'specif':151C 'store':5A,47B,82C 'suppli':189C 'track':166C 'trigger':150C 'user':142C 'version':102C 'via':7A,90C 'victim':154C 'visitor':53B,71C 'vulner':80C 'web':133C 'whenev':140C 'without':74C 'wordpress':1A,21B,23B,28B,78C 'wordpress-plugin':22B 'xss':6A","nicknames":[],"mitigations":[],"who_affected":"Sites running Document Embedder `2.4.0` or earlier where contributors or higher can publish or edit pages with embedded documents. Visitors to those pages are the victims. Sites without the plugin, or where only trusted editors write content, have lower exposure.","tier":"C","verified":{},"analyst_revisit_at":null,"first_public_at":"2026-10-28T07:16:44+00:00","kev":null,"cvss_vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","cvss_by":"security@wordfence.com","poc_count":0,"sources":[{"source":"nvd","external_id":"CVE-2026-109370","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-109370","severity":null,"published_at":"2026-10-28T07:16:44+00:00","modified_at":"2026-10-28T07:16:44+00:00","first_seen_at":"2026-10-28T07:31:37+00:00","fetched_at":"2026-10-28T07:31:37+00:00","note":null}],"documents":[],"notice":"Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai"}