---
id: "CVE-2026-109234"
kind: "vulnerability"
aliases: ["CVE-2026-109234"]
title: "WordPress Meow Lightbox plugin: stored XSS via bbPress replies"
severity: "high"
cvss: 7.2
epss: null
exploited: false
status: "open"
category: "package"
products: [{"name": "meow-lightbox", "fixed": ["5.6.5"], "affected": "<= 5.6.4", "ecosystem": "wordpress-plugin"}]
ecosystems: []
tags: ["bbpress", "meow-lightbox", "package", "wordpress", "wordpress-plugin"]
not_affected_if: ["default-config", "no-bbpress-anonymous-replies", "output-buffering-disabled"]
published_at: "2026-10-31T06:16:31+00:00"
first_seen_at: "2026-10-31T06:33:49+00:00"
updated_at: "2026-10-31T06:35:37+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-109234", "first_seen_at": "2026-10-31T06:33:49+00:00"}, {"source": "analyst", "url": null, "first_seen_at": "2026-10-31T06:35:37+00:00"}]
---

# WordPress Meow Lightbox plugin: stored XSS via bbPress replies

The Meow Lightbox plugin for WordPress does not sanitize the bbPress reply body, so stored script can be injected. Anyone who views the injected page runs attacker JavaScript in their browser session.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- wordpress-plugin:meow-lightbox affected <= 5.6.4 fixed 5.6.5

## How to check

- Check whether the Meow Lightbox plugin is installed and its version is `5.6.4` or lower.
- Check whether Output Buffering, the HtmlDomParser engine and Aggressive Resolve are enabled in the plugin settings.
- Check whether bbPress anonymous replies are enabled on the site.

## Fix

Update Meow Lightbox to 5.6.5 or later (released 2026/10/30). Until then, turn off Output Buffering or the HtmlDomParser engine / Aggressive Resolve, or disable anonymous bbPress replies.

## Timeline

- 2026-10-31T06:33:49+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-109234
- 2026-10-31T06:35:37+00:00 analyst — 5.6.5 changelog (wordpress.org) lists a security fix escaping attributes when the HTML parser rewrites a tag with a duplicated attribute; it does not name the CVE, but matches the parser-desync description and Patchstack lists 5.6.5 as latest. Fix inferred, not verified; no vendor advisory found, so nothing marked verified. No exploitation or PoC seen.

## Documents

- [advisory] Patchstack: Meow Lightbox <= 5.6.4 unauthenticated stored XSS https://patchstack.com/database/wordpress/plugin/meow-lightbox/vulnerability/wordpress-meow-lightbox-plugin-5-6-4-unauthenticated-stored-cross-site-scripting-vulnerability
- [fix] Meow Lightbox changelog (5.6.5, 2026/10/30) https://wordpress.org/plugins/meow-lightbox/

## From the sources

The Meow Lightbox plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'post_content (bbPress reply body)' parameter in all versions up to, and including, 5.6.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This requires the administrator to have enabled Output Buffering, the HtmlDomParser engine, and Aggressive Resolve, as well as a stored-HTML submission surface (such as bbPress anonymous replies) whose kses allow-list preserves img attributes; given these preconditions, a one-shot unauthenticated submission can execute arbitrary JavaScript in the context of any user who views the affected page.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
