---
id: "CVE-2026-105077"
kind: "vulnerability"
aliases: ["CVE-2026-105077"]
title: "Ad Inserter WordPress plugin: unauthenticated XSS through 2.8.19"
severity: "high"
cvss: 7.1
epss: null
exploited: false
status: "open"
category: "package"
products: [{"name": "ad-inserter", "fixed": ["2.8.20"], "affected": "<= 2.8.19", "ecosystem": "wordpress-plugin"}]
ecosystems: []
tags: ["ad-inserter", "package", "self-hosted", "wordpress", "wordpress-plugin", "xss"]
not_affected_if: ["managed-hosting-without-plugin", "plugin-not-installed"]
published_at: "2026-10-30T19:17:58+00:00"
first_seen_at: "2026-10-30T19:25:26+00:00"
updated_at: "2026-10-30T19:32:24+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-105077", "first_seen_at": "2026-10-30T19:25:26+00:00"}, {"source": "analyst", "url": null, "first_seen_at": "2026-10-30T19:32:24+00:00"}]
---

# Ad Inserter WordPress plugin: unauthenticated XSS through 2.8.19

Ad Inserter, a WordPress plugin, has an unauthenticated cross-site scripting flaw in versions up to and including 2.8.19. An attacker can inject script that runs in a visitor's or administrator's browser.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- wordpress-plugin:ad-inserter affected <= 2.8.19 fixed 2.8.20

## How to check

Run `wp plugin get ad-inserter --field=version` or see Plugins in wp-admin; versions <= 2.8.19 are affected, 2.8.20 or later is the target.

## Fix

Update Ad Inserter to 2.8.20 (current release; its changelog lists several XSS fixes, vendor does not map them to this CVE id).

## Timeline

- 2026-10-30T19:25:26+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-105077
- 2026-10-30T19:32:24+00:00 analyst — NVD gives no endpoint/param. wordpress.org changelog: 2.8.20 is current and fixes several XSS, but does not name this CVE; 2.8.19 changelog has one XSS fix (already shipped), so this one is presumably fixed in 2.8.20 (inference, not verified). Sibling CVEs (<=2.8.18) were fixed in 2.8.19. No exploitation or PoC found.

## Documents

- [fix] Ad Inserter changelog (wordpress.org) https://wordpress.org/plugins/ad-inserter/
- [mentions] Patchstack: Ad Inserter vulnerability history https://patchstack.com/database/wordpress/plugin/ad-inserter/vulnerabilities

## From the sources

Unauthenticated Cross Site Scripting (XSS) in Ad Inserter <= 2.8.19 versions.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
