{"id":"CVE-2026-104694","kind":"vulnerability","aliases":["CVE-2026-104694"],"related":[],"title":"Thrive Automator WordPress plugin: editor users can run blind SQL injection","description":"The Thrive Automator WordPress plugin before 11.2 does not properly sanitize and escape a parameter's array key before using it in a SQL query, allowing authenticated attackers with editor-level access to perform blind SQL injection attacks.","summary":"The Thrive Automator WordPress plugin before 11.2 does not sanitize a parameter's array key before using it in a SQL query. An authenticated user with editor-level access can use this to run blind SQL injection and read database contents.","severity":"high","cvss":null,"epss":null,"exploited":false,"exploited_at":null,"products":[],"ecosystems":[],"tags":["package","self-hosted","wordpress","wordpress-plugin"],"not_affected_if":["no-editor-accounts","plugin-version-11.2-or-later"],"how_to_check":"- Check the installed Thrive Automator plugin version in the WordPress admin under Plugins; versions below `11.2` are affected.\n- Run `wp plugin get thrive-automator --field=version` if WP-CLI is available (plugin slug unknown from sources; confirm with `wp plugin list`).","fix":"- Update the Thrive Automator plugin to `11.2` or later.\n- Until updated, review which accounts hold editor role and remove unneeded editor access.","status":"open","published_at":"2026-10-28T06:16:32+00:00","first_seen_at":"2026-10-28T06:31:26+00:00","triaged_at":"2026-10-28T06:32:54+00:00","updated_at":"2026-10-28T06:32:54+00:00","category":"package","confidence":0.6,"triage":{"at":"2026-10-28T06:32:54Z","model":"claude-haiku-5-5","output":{"fix":"- Update the Thrive Automator plugin to `11.2` or later.\n- Until updated, review which accounts hold editor role and remove unneeded editor access.","reach":"internet","title":"Thrive Automator WordPress plugin: editor users can run blind SQL injection","impact":"high","summary":"The Thrive Automator WordPress plugin before 11.2 does not sanitize a parameter's array key before using it in a SQL query. An authenticated user with editor-level access can use this to run blind SQL injection and read database contents.","category":"package","nicknames":[],"who_cares":["wordpress","wordpress-plugin","self-hosted"],"confidence":0.6,"needs_auth":"yes","worst_case":"Attacker with editor login reads database contents, including user and credential data.","analyst_note":"Confirm the plugin's exact vulnerable endpoint and the affected version range from the NVD entry or the plugin vendor's changelog.","how_to_check":"- Check the installed Thrive Automator plugin version in the WordPress admin under Plugins; versions below `11.2` are affected.\n- Run `wp plugin get thrive-automator --field=version` if WP-CLI is available (plugin slug unknown from sources; confirm with `wp plugin list`).","needs_analyst":true,"not_affected_if":["plugin-version-11.2-or-later","no-editor-accounts"],"who_is_affected":"Sites running the Thrive Automator WordPress plugin before 11.2 are exposed. The attacker needs an editor-level account, so sites that give editor accounts only to trusted staff have lower exposure. Sites without this plugin are not affected.","user_interaction":"no","needs_special_setup":"unknown","severity_if_unknown":"high"},"cost_usd":0.00063,"input_tokens":3291,"output_tokens":601,"severity_before":"unknown"},"analyst_status":null,"analyst_note":null,"search":"'-104694':14A,17A '-2026':13A,16A '11.2':32B,74C 'access':55B,100C 'allow':93C 'array':39B,84C 'attack':95C,106C 'authent':49B,94C 'autom':2A,28B,70C 'blind':9A,61B,103C 'content':67B 'cve':12A,15A 'databas':66B 'editor':5A,53B,98C 'editor-level':52B,97C 'escap':80C 'host':21B 'inject':11A,63B,105C 'key':40B,85C 'level':54B,99C 'packag':18B 'paramet':37B,82C 'perform':102C 'plugin':4A,25B,30B,72C 'proper':77C 'queri':47B,92C 'read':65B 'run':8A,60B 'sanit':35B,78C 'self':20B 'self-host':19B 'sql':10A,46B,62B,91C,104C 'thrive':1A,27B,69C 'use':42B,57B,87C 'user':6A,50B 'wordpress':3A,22B,24B,29B,71C 'wordpress-plugin':23B","nicknames":[],"mitigations":[],"who_affected":"Sites running the Thrive Automator WordPress plugin before 11.2 are exposed. The attacker needs an editor-level account, so sites that give editor accounts only to trusted staff have lower exposure. Sites without this plugin are not affected.","tier":"B","verified":{},"analyst_revisit_at":null,"first_public_at":"2026-10-28T06:16:32+00:00","kev":null,"cvss_vector":null,"cvss_by":null,"poc_count":0,"sources":[{"source":"nvd","external_id":"CVE-2026-104694","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-104694","severity":null,"published_at":"2026-10-28T06:16:32+00:00","modified_at":"2026-10-28T06:16:32+00:00","first_seen_at":"2026-10-28T06:31:26+00:00","fetched_at":"2026-10-28T06:31:26+00:00","note":null}],"documents":[],"notice":"Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai"}