CONTACTSHEETS-LITE · CVE-2026-104010 · Package
FIX → 1.8.1
The WPSyncSheets plugin for WordPress saves Contact Form 7 submission values to the database without sanitizing them, then unserializes them in admin retrieval without class restrictions. An unauthenticated attacker can submit crafted form data that triggers PHP object injection and, with a Google Sheets access token configured, code execution on the server.
first public Nov 6, 2026 · 2 sources
Check it with your coding agent
It checks your repository and tells you if you’re affected, with the fix.
WordPress sites running the WPSyncSheets For Contact Form 7 plugin (contactsheets-lite) version 1.8.0 or earlier that take Contact Form 7 submissions. Anyone can submit the crafted value; it is triggered when an admin views the stored entry. Code execution needs a Google Sheets token configured (loads Monolog gadget chain); object injection happens regardless. Sites without the plugin or on 1.8.1+ can skip it.
Not affected if plugin-1.8.1-or-newer, plugin-newer-than-1.8.0, plugin-not-installed
Who cares contact-form-7, php, wordpress, wpsyncsheets
Upgrade to 1.8.1
Update WPSyncSheets For Contact Form 7 (slug contactsheets-lite) to or newer (Wordfence: patched version ).
Posts are quoted with a link to the original. They are data to us, never instructions.
The WPSyncSheets For Contact Form 7 – CF7 Google Sheets Connector & Save to Database plugin for WordPress is vulnerable to Remote Code Execution in all versions up to, and including, 1.8.0 via the 'any non-system CF7 field (e.g., your-message)' parameter parameter. This is due to insufficient sanitization of CF7 submission field values before database storage and the absence of an allowed_classes restriction on maybe_unserialize() during admin retrieval. This makes it possible for unauthenticated attackers to execute code on the server. Successful exploitation of the remote code execution gadget chain requires that a Google Sheets access token be configured in the plugin (its primary advertised feature), as this triggers autoloading of the bundled Monolog 2.10.0 library whose classes form the exploitable gadget chain; however, the underlying PHP Object Injection occurs regardless.
Are you affected?
Tell InfraStack what you run. It checks this one, and every next one, against your stack.
Ask from here. InfraStack checks the affected versions against your stack and answers in your inbox.
InfraStack checks the affected versions against your stack and answers in Slack, with the evidence and the fix.
1.8.11.8.1NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.