---
id: "CVE-2026-103882"
kind: "vulnerability"
aliases: ["CVE-2026-103882"]
title: "Acadlix LMS WordPress plugin: arbitrary file deletion leads to code execution"
severity: "critical"
cvss: 9.1
epss: 0.00787
exploited: false
status: "open"
category: "package"
products: [{"name": "acadlix", "fixed": ["1.2.0"], "affected": "<= 1.1.9", "ecosystem": "wordpress-plugin"}]
ecosystems: ["wordpress-plugin"]
tags: ["acadlix", "acadlix-lms", "package", "self-hosted", "wordpress"]
not_affected_if: ["plugin-not-installed", "plugin-updated-to-1.2.0"]
published_at: "2026-10-31T09:16:32+00:00"
first_seen_at: "2026-10-31T09:34:41+00:00"
updated_at: "2026-10-31T18:03:04+00:00"
sources: [{"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2026-103882", "first_seen_at": "2026-10-31T09:34:41+00:00"}, {"source": "analyst", "url": null, "first_seen_at": "2026-10-31T09:37:15+00:00"}, {"source": "epss", "url": "https://api.first.org/data/v1/epss?cve=CVE-2026-103882", "first_seen_at": "2026-10-31T18:03:04+00:00"}]
---

# Acadlix LMS WordPress plugin: arbitrary file deletion leads to code execution

The Acadlix LMS WordPress plugin up to and including 1.1.9 lets a user delete arbitrary files on the server because file paths are not validated. Deleting a file such as wp-config.php can lead to remote code execution, and the nonce check can be satisfied by any visitor, so effectively no login is needed.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- wordpress-plugin:acadlix affected <= 1.1.9 fixed 1.2.0

## How to check

Run `wp plugin get acadlix --field=version` (slug is acadlix), or check Plugins in wp-admin. Version 1.1.9 or lower is vulnerable; 1.2.0 is the first release after 1.1.9. Look for wp-content/plugins/acadlix/.

## Fix

Update the Acadlix LMS plugin (WordPress.org slug: acadlix) to 1.2.0 or later. The 1.2.0 changelog (23 Oct 2026) lists 'a security issue' reported by Wordfence; the vendor does not name the CVE or the file-deletion bug, so the mapping is inferred from the CVE affecting <= 1.1.9.

## Timeline

- 2026-10-31T09:34:41+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2026-103882
- 2026-10-31T09:37:15+00:00 analyst — Slug acadlix and 1.2.0 (23-10-2026) from wordpress.org/acadlix changelog + acadlix.com/changelog; vendor only says 'a security issue, thanks Wordfence', so the fix is inferred and not marked verified. Description says subscriber-level, but the nonce is public, so effectively unauthenticated (Wordfence title says Unauthenticated). No exploitation or PoC found; no social search done (new CVE).
- 2026-10-31T18:03:04+00:00 epss https://api.first.org/data/v1/epss?cve=CVE-2026-103882

## Documents

- [advisory] NVD CVE-2026-103882 (Wordfence CNA) https://nvd.nist.gov/vuln/detail/CVE-2026-103882
- [fix] Acadlix LMS on WordPress.org (changelog 1.2.0, 1.1.9) https://wordpress.org/plugins/acadlix/
- [fix] Acadlix changelog https://acadlix.com/changelog/

## From the sources

The Acadlix LMS – AI Quiz Maker, Online Exam & Course Plugin for WordPress plugin for WordPress is vulnerable to arbitrary file deletion due to insufficient file path validation in the post_delete_assessment_file_by_id function in all versions up to, and including, 1.1.9. This makes it possible for authenticated attackers, with subscriber-level access and above, to delete arbitrary files on the server, which can easily lead to remote code execution when the right file is deleted (such as wp-config.php). The route's permission callback only verifies a generic wp_rest nonce that the plugin itself emits inside the public acadlixOptions JavaScript object on every frontend page, effectively reducing the authentication requirement to unauthenticated.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
