---
id: "CVE-2025-67895"
kind: "vulnerability"
aliases: ["CVE-2025-67895", "GHSA-66h8-3g48-6hx8"]
title: "Apache Airflow Providers Edge3 exposes internal API allowing RCE in web server context"
severity: "critical"
cvss: 9.8
epss: 0.01168
exploited: false
status: "open"
category: "package"
products: [{"name": "apache-airflow-providers-edge3", "fixed": ["2.0.0"], "affected": "< 2.0.0", "ecosystem": "pypi"}, {"name": "apache apache-airflow-providers-edge3", "fixed": ["2.0.0"], "affected": "< 2.0.0", "ecosystem": "vendor"}]
ecosystems: ["pypi", "vendor"]
tags: ["airflow", "cwe-669", "package", "pypi", "python", "self-hosted"]
not_affected_if: ["airflow-3", "edge3-not-installed", "no-dag-author-trust-issue"]
published_at: "2025-12-17T12:15:46+00:00"
first_seen_at: "2026-10-26T21:21:58+00:00"
updated_at: "2026-10-26T21:55:22+00:00"
sources: [{"source": "ghsa", "url": "https://github.com/advisories/GHSA-66h8-3g48-6hx8", "first_seen_at": "2026-10-26T21:21:58+00:00"}, {"source": "nvd", "url": "https://nvd.nist.gov/vuln/detail/CVE-2025-67895", "first_seen_at": "2026-10-26T21:55:22+00:00"}]
---

# Apache Airflow Providers Edge3 exposes internal API allowing RCE in web server context

The Edge3 provider for Apache Airflow 2 enabled an internal, non-public API that let a DAG author execute code in the webserver context. An attacker with DAG authoring rights can run arbitrary code on the Airflow webserver.

_Summary, check and fix written by a model from the sources; labelled as such._

## Affected

- pypi:apache-airflow-providers-edge3 affected < 2.0.0 fixed 2.0.0
- vendor:apache apache-airflow-providers-edge3 affected < 2.0.0 fixed 2.0.0

## How to check

- `pip show apache-airflow-providers-edge3` to see the installed provider version, and `airflow version` to see whether the host runs Airflow 2 or 3
- Check whether the Edge3 provider is listed in the project's requirements or Dockerfile and whether it is configured in Airflow 2 deployments

## Fix

- Upgrade `apache-airflow-providers-edge3` to `2.0.0` or later, which requires Airflow 3
- On Airflow 2, uninstall the Edge3 provider and migrate to Airflow 3 as the advisory recommends

## Timeline

- 2026-10-26T21:21:58+00:00 ghsa https://github.com/advisories/GHSA-66h8-3g48-6hx8
- 2026-10-26T21:55:22+00:00 nvd https://nvd.nist.gov/vuln/detail/CVE-2025-67895

## From the sources

Edge3 Worker RPC RCE on Airflow 2.

This issue affects Apache Airflow Providers Edge3: before 2.0.0 - and only if projects installed and configured it on Airflow 2.

The Edge3 provider support in Airflow 2 has been always development-only and not officially released, however if projects installed and configured Edge3 provider in Airflow 2, it implicitly enabled non-public (normally) API which was used to test Edge Provider in Airflow 2 during the development. This API allowed Dag author to perform Remote Code Execution in the webserver context, which Dag Author was not supposed to be able to do.

If projects installed and configured Edge3 provider for Airflow 2, they should uninstall it and migrate to Airflow 3. The new Edge3 provider versions (>=2.0.0) has a minimum version of Airflow set to 3 and the RCE-prone Airflow 2 code is removed, so it should no longer be possible to use the Edge3 provider 2.0.0+ on Airflow 2.

If projects used Edge Provider in Airflow 3, you they are not affected.

---

_Free to read at a human pace. An API with keys and an MCP server are in preparation; early access: hello@infrastack.ai_
