Live › vulnerability › CVE-2025-58438
Go to dashboardThe internetarchive Python library's File.download() does not sanitize filenames or check the final download path, so a crafted filename with traversal sequences writes files outside the intended directory. An attacker who controls a filename the library downloads can overwrite system or application config files, which the advisory says can lead to denial of service, privilege escalation or remote code execution.
Summary written from the sources below. Check the originals before acting.
First seen by InfraStack 2026-10-27 17:27 UTC, 0h before NVD. All times on this page are UTC.
Any application that uses internetarchive versions up to and including 5.5.0 to call File.download() on filenames it does not fully control, such as names taken from Internet Archive item metadata or user input. The advisory says Windows systems are especially at risk, but all operating systems are affected. Projects that do not use this library, or that pin 5.5.1 or later, can skip it.
| Product | Ecosystem | Affected | Fixed in |
|---|---|---|---|
| internetarchive | pypi | <= 5.5.0 | 5.5.1 |
pip show internetarchive and check whether the version is below 5.5.1requirements.txt, poetry.lock or Pipfile.lock for internetarchive pinned below 5.5.1internetarchive package to 5.5.1 or later (pip install --upgrade internetarchive>=5.5.1)Each row is the first time that source carried this signal. The analyst’s rows are its own findings.
What kind of vulnerability is it?
This is a Critical severity directory traversal (path traversal) vulnerability in the File.download() method of the internetarchive library.
Who is impacted?
All users of the internetarchive library versions < 5.5.1 are impacted. The vulnerability is particularly critical for users on Windows systems, but all operating systems are affected.
Description of the vulnerability:
The vulnerability existed because the file.download() method did not properly sanitize user-supplied filenames or validate the final download path. A maliciously crafted filename could contain path traversal sequences (e.g., ../../../../windows/system32/file.txt) or illegal characters that, when processed, would cause the file to be written outside of the intended target directory.
Potential Impact: An attacker could potentially overwrite critical system files or application configuration files, leading to a denial of service, privilege escalation, or remote code execution, depending on the context in which the library is used.
Has the problem been patched? Yes, the problem has been patched.
What versions should users upgrade to? Users must upgrade to version 5.5.1 or later.
Is there a way for users to fix or remediate the vulnerability without upgrading? There is no direct workaround that does not involve upgrading the library. The vulnerability is in the core logic of the file download process.
The only alternative for users who absolutely cannot upgrade is to implement their own custom download function that:
However, this essentially re-implements the fix and is not recommended. Upgrading to the patched version is the only safe and supported solution.
This page as .md · .json · in your agent: get_signal("CVE-2025-58438")
GitHub Advisory Database, CC-BY 4.0 · NVD data is provided by NIST and is public domain. Posts quoted belong to their authors.